Monster MotorsportJMB Retrofits
Results 1 to 36 of 36
  1. #1
    vfr800's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Melting Beans
    Posts
    740

    Weird Xenon Problem?

    Hi

    I have an intermittent problem with my Xenons.

    When I get in the car, turn the engine on, then switch the headlights on after a few seconds BOTH xenons switch off at exactly the same time.

    It happened yesterday when the car was cold in the evening. Got in switched on they came to life, and then went off, I switched off the headlights switched them back on after a few seconds and they worked fine.

    Tonight, they went off, I switched them off and back on and they came back. I pulled away and got up to about 15 mph and they went off again. I pulled over and switched the switch off and it took a good 15-20 seconds before they'd power up again.

    It's an intermittent problem so I can't test it easily.

    Is this a problem anyone has seen before?

    Each side is fused independently and the fuses are ok. Are there any common electrical circuits or control systems that would affect both lights at once?

    The bulb out warning(s) did NOT come on.

    Are there any relays that might go bad or could it be the headlight switch itself?

    Thanks, Liam

    S3 AMK 2002. Only 203 BHP left in my poor little engine, currently searching for the 7 missing horses.
    Mods: Powerflex bushes at the front and rear, 710P DV, ambient light module, Badger5 V3 TIP, S2000 Filter.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,389
    Switch?

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  4. #3
    vfr800's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Melting Beans
    Posts
    740
    Quote Originally Posted by aragorn View Post
    Switch?
    Thanks. It's a possibility I've thought of - I guess the problem will become more apparent and then I can try narrow it down.

    I've done a lot of googling and not found anyone with the same problem.

    S3 AMK 2002. Only 203 BHP left in my poor little engine, currently searching for the 7 missing horses.
    Mods: Powerflex bushes at the front and rear, 710P DV, ambient light module, Badger5 V3 TIP, S2000 Filter.

  5. #4
    Pushing the limits..

    Status
    Offline
    Join Date
    Jan 2011
    Location
    Australia
    Posts
    1,316

    My Social Networking

    Add Sevv on Facebook
    ive had the same issue (sort off) after change the xenon's mate they turn on then off in a matter of a second.. though putting the old bulbs on fixed it, other suggested it might be the ballast

  6. #5
    6th Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    RETFORD, NOTTS
    Posts
    1,753
    Try wiggling the switch around with the lights on, possibly a dry contact. Or the relay not likeing the cold/damp ? highly unlikely to be both ballasts or both lights going by your description.
    '02 TDi 130 Sport: Mods to date: BXP 160 conversion, EGR delete, Decat, Helix SMF fast road clutch, 312mm front rotors, full DIS , CC, Xenons.
    VCDS fully registered and happy to help.
    *Need a Spare Key or Remote? SKC retrieval? Clock/ECU swap or milage correction? I am fully insured to work on your vehicle! Offering a good deal and quality service to ASN members Nationwide!*

  7. #6
    vfr800's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Melting Beans
    Posts
    740
    Quote Originally Posted by @udi A3 View Post
    Try wiggling the switch around with the lights on, possibly a dry contact. Or the relay not likeing the cold/damp ? highly unlikely to be both ballasts or both lights going by your description.
    I did give the switch a little wiggle - might wiggle a bit more forcefully tomorrow.

    About once a month I get a xenon that doesn't power up.

    This is both switching off after a few seconds, seeing as both sides are independently fused it's got to be a fault with a common part i.e. the switch or relay.

    Do you know which relay might be the culprit?

    S3 AMK 2002. Only 203 BHP left in my poor little engine, currently searching for the 7 missing horses.
    Mods: Powerflex bushes at the front and rear, 710P DV, ambient light module, Badger5 V3 TIP, S2000 Filter.

  8. #7
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,389
    Not familiar with the A3, but the A4 doesnt have a relay, the switch contacts take all the load.

    The fact you didnt get a bulb out warning also suggests it has to be before the power gets to the bulb monitoring device. Its wired up switch -> bulb monitor > fuses > ballasts > lamps

    If anything after the bulb monitor caused it, you'd expect to get the warning on the dash.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  9. #8
    jojo's Avatar
    S3 Drift King!

    Status
    Offline
    Join Date
    Sep 2003
    Location
    Solihull, Midlands
    Posts
    25,592
    My guess is the switch, on my S3, if one of the xenons don't fire up, I get a bulb out warning on the DIS, so I have to flick the switch off and back on again to flick it on. Usually only happens when the weather starts to go cold, like this time of year! It won't hurt to take the switch out and inspect the plugs first. You need to push the switch knob inward, it's spring loaded, the rotate clockwise, then pull the whole thing out.
    Last edited by jojo; 14th November 2012 at 12:55.



    99' Audi S3(APY) - Brilliant Black Click>>>Going Sideways vid!
    You've got to have a laugh! For Sale:LCR Brakes - £400



  10. #9
    vfr800's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Melting Beans
    Posts
    740
    aragon, jojo - cheers guys. I'm feeling a bit happier that my car doesn't have an electrical gremlin that will require me to set light to it and buy a new one!

    S3 AMK 2002. Only 203 BHP left in my poor little engine, currently searching for the 7 missing horses.
    Mods: Powerflex bushes at the front and rear, 710P DV, ambient light module, Badger5 V3 TIP, S2000 Filter.

  11. #10
    vfr800's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Melting Beans
    Posts
    740
    oki so I went and pulled the switch out and the connector came out of the back of the switch without having to press the tabs in ... terminals didn't look burnt or anything so perhaps it wasn't seated properly and I've been lucky/got away with it.

    Liam

    EDIT: Have done a little video showing how easy it is to remove the headlight switch.

    Last edited by vfr800; 14th November 2012 at 12:53.

    S3 AMK 2002. Only 203 BHP left in my poor little engine, currently searching for the 7 missing horses.
    Mods: Powerflex bushes at the front and rear, 710P DV, ambient light module, Badger5 V3 TIP, S2000 Filter.

  12. #11
    jojo's Avatar
    S3 Drift King!

    Status
    Offline
    Join Date
    Sep 2003
    Location
    Solihull, Midlands
    Posts
    25,592
    Good work Liam, lets hope that's a fix! Just edited my post above to rotate clockwise for release of headlamp switch! lol
    Your headlamp switch looks rather worn though mate.



    99' Audi S3(APY) - Brilliant Black Click>>>Going Sideways vid!
    You've got to have a laugh! For Sale:LCR Brakes - £400



  13. #12
    vfr800's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Melting Beans
    Posts
    740
    Quote Originally Posted by jojo View Post
    Good work Liam, lets hope that's a fix! Just edited my post above to rotate clockwise for release of headlamp switch! lol
    Your headlamp switch looks rather worn though mate.
    Yeah it is rather worn BUT I just searched ebay for my switch's part number and found a brand spanky new one being sold by Cardiff Audi for £20. So I bought it!

    Thanks for your help!

    S3 AMK 2002. Only 203 BHP left in my poor little engine, currently searching for the 7 missing horses.
    Mods: Powerflex bushes at the front and rear, 710P DV, ambient light module, Badger5 V3 TIP, S2000 Filter.

  14. #13
    The Doctor's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Jul 2009
    Location
    Planet Earth
    Posts
    1,197
    Wow that sounds like a bargain Liam. I consciously try not to catch the outer lip around the headlight switch with my fingers when I put the lights on, so that I don't wear the grey coating off. OMG my OCD is becoming more and more "O" with every passing year. By the time I'm 40 I reckon I'll be putting on white cotton gloves before I even get into the car.

    Anyway, post an update to let us know if this has solved the mystery.

    Oh, I like your updated signature by the way!

  15. #14
    vfr800's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Melting Beans
    Posts
    740
    Hi

    Quote Originally Posted by The Doctor View Post
    Wow that sounds like a bargain Liam. I consciously try not to catch the outer lip around the headlight switch with my fingers when I put the lights on, so that I don't wear the grey coating off. OMG my OCD is becoming more and more "O" with every passing year. By the time I'm 40 I reckon I'll be putting on white cotton gloves before I even get into the car.

    Anyway, post an update to let us know if this has solved the mystery.

    Oh, I like your updated signature by the way!
    Thanks. I've got nothing very interesting to post about my car except my loss of power :P

    It really bugs me that the coating is coming off the switches, I have also been watching ebay for similar aircon and radio controls so I can swap the facias over. You interior is amazingly mint - very jealous.

    lol so I don't have to be too OCD with my motorbike I bought an extra set of fairings, had them resprayed and stuck them in the loft so I can scratch the bike now and don't need to give a sh*t.

    I think you'll find cotton gloves might be a bit too abrasive but I think the oils or grease on fingers might also break down the coating as is seems to have gone a bit gooey over time.

    The problem didn't re-occur yesterday so I think it was the connector not being seated properly. I will post back if it comes back.

    Liam

    S3 AMK 2002. Only 203 BHP left in my poor little engine, currently searching for the 7 missing horses.
    Mods: Powerflex bushes at the front and rear, 710P DV, ambient light module, Badger5 V3 TIP, S2000 Filter.

  16. #15
    vfr800's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Melting Beans
    Posts
    740
    Just arrived in the post not bad considering I ordered it yesterday afternoon.


    S3 AMK 2002. Only 203 BHP left in my poor little engine, currently searching for the 7 missing horses.
    Mods: Powerflex bushes at the front and rear, 710P DV, ambient light module, Badger5 V3 TIP, S2000 Filter.

  17. #16
    jojo's Avatar
    S3 Drift King!

    Status
    Offline
    Join Date
    Sep 2003
    Location
    Solihull, Midlands
    Posts
    25,592
    MINT!



    99' Audi S3(APY) - Brilliant Black Click>>>Going Sideways vid!
    You've got to have a laugh! For Sale:LCR Brakes - £400



  18. #17
    vfr800's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Melting Beans
    Posts
    740
    Quote Originally Posted by jojo View Post
    MINT!
    Minter! Need a new lower dash though to match it now though.

    S3 AMK 2002. Only 203 BHP left in my poor little engine, currently searching for the 7 missing horses.
    Mods: Powerflex bushes at the front and rear, 710P DV, ambient light module, Badger5 V3 TIP, S2000 Filter.

  19. #18
    IFFY_77's Avatar
    Neutral

    Status
    Offline
    Join Date
    Jun 2012
    Location
    London
    Posts
    68
    Quote Originally Posted by jojo View Post
    My guess is the switch, on my S3, if one of the xenons don't fire up, I get a bulb out warning on the DIS, so I have to flick the switch off and back on again to flick it on. Usually only happens when the weather starts to go cold, like this time of year! It won't hurt to take the switch out and inspect the plugs first. You need to push the switch knob inward, it's spring loaded, the rotate clockwise, then pull the whole thing out.

    I been getting this same problem when one left xenon lights up right does not and bulb warning light on dash. Just got flick it on n off again to sort it out. But is thr a permanent fix to this or is right bulb on its way out any av you fixed urs. ( it's also a intermittent problem) little thugs annoy me....:-s

  20. #19
    Pushing the limits..

    Status
    Offline
    Join Date
    Jan 2011
    Location
    Australia
    Posts
    1,316

    My Social Networking

    Add Sevv on Facebook
    i have the same problem but thats after changing my bulbs so put the old ones.. check the connections and fuses. blown fuse possibly?

  21. #20
    vfr800's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Melting Beans
    Posts
    740
    Quote Originally Posted by Sevv View Post
    i have the same problem but thats after changing my bulbs so put the old ones.. check the connections and fuses. blown fuse possibly?
    Hi Sevv.

    This problem was particular, both lights were going off/coming back on together and I wasn't getting a bulb out warning.

    If you read my original post you'll see I did check the fuses.

    Thanks, Liam

    S3 AMK 2002. Only 203 BHP left in my poor little engine, currently searching for the 7 missing horses.
    Mods: Powerflex bushes at the front and rear, 710P DV, ambient light module, Badger5 V3 TIP, S2000 Filter.

  22. #21
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,389
    if your getting the bulb out warning, then its not the switch.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  23. #22
    jojo's Avatar
    S3 Drift King!

    Status
    Offline
    Join Date
    Sep 2003
    Location
    Solihull, Midlands
    Posts
    25,592
    Quote Originally Posted by IFFY_77 View Post
    I been getting this same problem when one left xenon lights up right does not and bulb warning light on dash. Just got flick it on n off again to sort it out. But is thr a permanent fix to this or is right bulb on its way out any av you fixed urs. ( it's also a intermittent problem) little thugs annoy me....:-s
    Not really fixed it bud, I hardly use the car enough to warrant fixing this problem, it's not major in my opinion. The first thing you need to do if you really want to fix it is to swop the xenon bulbs around to see if the problem is still there. Of course it's not easy, as it only never comes on when everything is stone cold! If the same side doesn't come on, then it's the xenon ballast, if it's the otherside that doesn't come on, then it's the bulb.



    99' Audi S3(APY) - Brilliant Black Click>>>Going Sideways vid!
    You've got to have a laugh! For Sale:LCR Brakes - £400



  24. #23
    IFFY_77's Avatar
    Neutral

    Status
    Offline
    Join Date
    Jun 2012
    Location
    London
    Posts
    68
    Cheers jojo mite just do sum bulb testing on my days off to find out cant b that hard....

  25. #24
    Vex182's Avatar
    Guess what I drive...

    Status
    Offline
    Join Date
    Apr 2012
    Location
    Hinckley
    Posts
    899

    My Social Networking

    Add Vex182 on Facebook
    Quote Originally Posted by vfr800 View Post
    Yeah it is rather worn BUT I just searched ebay for my switch's part number and found a brand spanky new one being sold by Cardiff Audi for £20. So I bought it! Thanks for your help!
    I had to get one from Audi directly as mine packed up the day before my MOT and I had no working fogs, paid about £90 for it!
    Silver 2002 Audi S3 225 (BAM) since March 2011.

    Mods: Badger5 2.2 TIP, Jetex filter, PCV delete, 710 DV, Standard N249 in use, R-Tech Stage 1 TiV Remap, Audi TT Pedals, Red Dogbone, Polybushed tie arms. All silicone boost pipes, Michelin PS3s, Red V6 coil packs, MK4 flat blade conversion, retrofited cruise control.
    Currently: 254bhp - 276lb/ft (174bhp/ton) as of 11/02/2013 On V-Power

  26. #25
    Pushing the limits..

    Status
    Offline
    Join Date
    Jan 2011
    Location
    Australia
    Posts
    1,316

    My Social Networking

    Add Sevv on Facebook
    Quote Originally Posted by vfr800 View Post
    Hi Sevv.

    This problem was particular, both lights were going off/coming back on together and I wasn't getting a bulb out warning.

    If you read my original post you'll see I did check the fuses.

    Thanks, Liam
    yeah im getting the bulb out warning sadly so not sure how to diagnose ill have to check you previous thread as i think im just gonna change the fuses and see how it goes. i dont understand why old lights work fine but the new ones dont...to add to my mishaps i accidentally broke the bulb from the inside ***clumsy me***

    the best part i called Audi Five dock here in Sydney they wanted 660$ thats with a 100$ discount for me

  27. #26
    4th Gear

    Status
    Offline
    Join Date
    Feb 2006
    Location
    Lincolnshire
    Posts
    723
    I just replaced my headlight switch, a lot more than £20 though, that was a bargain!

    I replaced mine as it was all scratched up, and also because the red lights were flickering on and off.

    Interestingly, when I replaced the switch, the dark corners on my DIS also disappeared. I thought the DIS was failing, but when you see how many wires go into the headlight switch, and that the rheostat controls the lighting, I wonder if the switch was the culprit? Certainly, all the lights seem brighter on the dash pod/radio/doors everything.

    Generally speaking, when I've had a Xenon that wouldn't fire up it has been the bulb. Once it was the ballast/igniter.

    With both switching off, it would point to the switch or a relay.

    Hope it's fixed for you!
    Audi S3 - 2002MY - Denim Blue - Gone
    VW Polo GTI - 2011MY - Candy White - Here

  28. #27
    vfr800's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Melting Beans
    Posts
    740
    Quote Originally Posted by Tooks View Post
    With both switching off, it would point to the switch or a relay.

    Hope it's fixed for you!
    Thanks. Yes it seems to be all good now. Bit of a result as I wanted to replace the scratched up switch any way.

    Liam

    S3 AMK 2002. Only 203 BHP left in my poor little engine, currently searching for the 7 missing horses.
    Mods: Powerflex bushes at the front and rear, 710P DV, ambient light module, Badger5 V3 TIP, S2000 Filter.

  29. #28
    The Doctor's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Jul 2009
    Location
    Planet Earth
    Posts
    1,197
    Nice one Liam, glad it's sorted, especially as it's basically dark most of the time at this time of year.

  30. #29
    Pushing the limits..

    Status
    Offline
    Join Date
    Jan 2011
    Location
    Australia
    Posts
    1,316

    My Social Networking

    Add Sevv on Facebook
    can anyone advise me wether these bulbs would be fine to fit.. they are genuine phillips 6000K bulbs 81522 WX

    Philips D2S 6000k 85122WX Ultinon | eBay


    i tired my old bulbs out so switched the old one on either side at it would light up just fine just these crappy morimoto ones wouldnt so i came to the conclusion its the bulbs.. now to choose another .. just dont wanna bloody waste another 100$

  31. #30
    vfr800's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Melting Beans
    Posts
    740
    Hi

    They're D2S so should be fine. Philips is a good make IMHO.

    EDIT: I wouldn't go for 6k - ok so it's a pretty blue light but they're sh*t for seeing where you're going.

    Liam

    S3 AMK 2002. Only 203 BHP left in my poor little engine, currently searching for the 7 missing horses.
    Mods: Powerflex bushes at the front and rear, 710P DV, ambient light module, Badger5 V3 TIP, S2000 Filter.

  32. #31
    Pushing the limits..

    Status
    Offline
    Join Date
    Jan 2011
    Location
    Australia
    Posts
    1,316

    My Social Networking

    Add Sevv on Facebook
    Quote Originally Posted by vfr800 View Post
    Hi

    They're D2S so should be fine. Philips is a good make IMHO.

    EDIT: I wouldn't go for 6k - ok so it's a pretty blue light but they're sh*t for seeing where you're going.

    Liam
    thanks mate appreciate the reply i hope they work fine lol... driving without lights at night really sucks ill check the 4300K thanks again Liam

    Seb

  33. #32
    vfr800's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Melting Beans
    Posts
    740
    No worries. Thanks for the heads up on the Philips bulbs, I've just searched in the UK for those bulbs and they're about £55 for two. I might get some nice new ones @ 4.3k.

    Where in Aus are you? I'm flying to Sydney on 5th Dec for a 6 week holiday.

    S3 AMK 2002. Only 203 BHP left in my poor little engine, currently searching for the 7 missing horses.
    Mods: Powerflex bushes at the front and rear, 710P DV, ambient light module, Badger5 V3 TIP, S2000 Filter.

  34. #33
    Pushing the limits..

    Status
    Offline
    Join Date
    Jan 2011
    Location
    Australia
    Posts
    1,316

    My Social Networking

    Add Sevv on Facebook
    Quote Originally Posted by vfr800 View Post
    No worries. Thanks for the heads up on the Philips bulbs, I've just searched in the UK for those bulbs and they're about £55 for two. I might get some nice new ones @ 4.3k.

    Where in Aus are you? I'm flying to Sydney on 5th Dec for a 6 week holiday.
    wow dont forget ur shorts lol its gonna be bloody hot.. i live in Sydney 15 mins from the city.. where abouts in sydney are you staying

  35. #34
    vfr800's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Melting Beans
    Posts
    740
    Yeah I know - I'm not looking forward to it. I hate hot weather, I'm more of a cold weather person.

    Er... dunno where exactly, I'm staying with friends, I do one night in Sydney and then do a two week tour up the east coast, back to Sydney for one night, then off to Tasmania for Christmas. Melbourne just after Christmas and do the great ocean road over NYE. Then back to Sydney for a week or so to doss around.

    Liam

    S3 AMK 2002. Only 203 BHP left in my poor little engine, currently searching for the 7 missing horses.
    Mods: Powerflex bushes at the front and rear, 710P DV, ambient light module, Badger5 V3 TIP, S2000 Filter.

  36. #35
    Pushing the limits..

    Status
    Offline
    Join Date
    Jan 2011
    Location
    Australia
    Posts
    1,316

    My Social Networking

    Add Sevv on Facebook

    Re: Weird Xenon Problem?

    nice.. if we have time we should meet up

  37. #36
    vfr800's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Melting Beans
    Posts
    740
    Quote Originally Posted by Sevv View Post
    nice.. if we have time we should meet up
    I'm in Sydney now!

    Having humassive withdrawal symptoms - haven't been in my S3 for over a month now ;( Just drove up the Great Ocean road from Melbourne to Adelaide in a Hyundai i20 - what a piece of junk - awful steering, it didn't like going round corners and wouldn't track in a straight line.

    Liam

    S3 AMK 2002. Only 203 BHP left in my poor little engine, currently searching for the 7 missing horses.
    Mods: Powerflex bushes at the front and rear, 710P DV, ambient light module, Badger5 V3 TIP, S2000 Filter.

 

 

Similar Threads

  1. Weird Acceleration Problem
    By StokeTDi in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 2
    Last Post: 12th October 2007, 17:12
  2. xenon problem
    By cjp2k in forum A3/S3/Sportback (8P Chassis)
    Replies: 2
    Last Post: 9th May 2007, 21:08
  3. Xenon Problem
    By DavidW in forum A3/S3 Forum (8L Chassis)
    Replies: 3
    Last Post: 21st March 2007, 02:18
  4. Weird Stereo Problem
    By MartinM in forum A6/S6/Allroad forum (C5 Chassis)
    Replies: 2
    Last Post: 24th February 2006, 09:28
  5. Xenon problem...
    By dickys3 in forum A3/S3 Forum (8L Chassis)
    Replies: 8
    Last Post: 2nd October 2005, 17:14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO