Volks AutosMonster Motorsport
Results 1 to 37 of 37
Like Tree1Likes
  • 1 Post By Sam_

Thread: Uh oh, knocking...

  1. #1
    Sam_'s Avatar
    Down under

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Sydney, Australia
    Posts
    2,783

    Uh oh, knocking...

    It's not the rods heh. I've noticed of late that I sometimes I get the odd knocking on boost if I'm sudden or build up and then nail it (overtaking etc). It sounds very much like knocking/pinking so I let off straight away when it happens of course. It's random, and doesn't throw a fault code that I can see (liquid gauge says it's all clear). The car's on 120,000km (75,000 miles) so not that old. Plugs are probably around 15,000km old iridium NGKs but might be worth doing - was going to get BKUR7ETs and change more often? Fuel pump getting tired? MAF is genuine Bosch about the same age as the plugs, same for the coilpacks (bolt downs). Checked for misfires, nothing. The odd thing is that it drives ok whilst doing this (as in, smooth), but does feel a little underpowered. Which suggests to me running lean. I'll try to run the AFR gauge more and see whether it is running lean. The ambients will have picked up a little recently (getting towards summer, today was 30+) which probably doesn't help, if it's pinking.

    I've been granny-ing it until I know what's wrong

    Any ideas what it could be?
    Handling mods++. HTA3582 stroker soon-ish. Hiding parts from the mrs since 2011. Build thread

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,553
    Logged block 020?

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  4. #3
    Sam_'s Avatar
    Down under

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Sydney, Australia
    Posts
    2,783
    Yeah I think it needs a proper VCDS session. I had issues doing logging before (eBay cable with Lite software, on a MacBook with VM...) but I will try again.

    What's block 20 for?
    Handling mods++. HTA3582 stroker soon-ish. Hiding parts from the mrs since 2011. Build thread

  5. #4
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,553
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  6. #5
    Sam_'s Avatar
    Down under

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Sydney, Australia
    Posts
    2,783
    Haha sorry - I should have googled...

    I did notice using the "Timing pull" function on the Liquid Gauge that I was getting 3.0 on #2 and 6.0 on #4 without even giving it death, and at less than 3.5k rpm. Can't be good?
    Adeyy likes this.
    Handling mods++. HTA3582 stroker soon-ish. Hiding parts from the mrs since 2011. Build thread

  7. #6
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,553
    No... getting 6's is fairly iffy...

    Pull the hose off the throttle body and see if its full of oil... (wet with...) clean it up and go for a drive... check to see if its back...

    Also... pull the hose off the top charge pipe (the one that goes behind the headlight) and see if oil is there... agian clean, drive and check...

    Oil here would suggest turbo seals... this oil will dilute the octane rating of the fuel and promote knock...

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  8. #7
    Sam_'s Avatar
    Down under

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Sydney, Australia
    Posts
    2,783
    Bugger. Cheers, full of good info as always. If it is the turbo, I might have to nurse it until I get the new engine built

    I'll chuck some new plugs in and give it a once over. It's due a service anyhow but I've been putting it off as I need to swap the sump and do the pickup. I know it's going to be a messy/fiddly job. Might have to attempt it this weekend.
    Handling mods++. HTA3582 stroker soon-ish. Hiding parts from the mrs since 2011. Build thread

  9. #8
    Sam_'s Avatar
    Down under

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Sydney, Australia
    Posts
    2,783
    Thinking about it, it has been burning/loosing a bit recently. I've been gradually topping it up more often, and it was mildly smokey (oily) on the dyno when the haldex was freaking out.

    Bugger++
    Handling mods++. HTA3582 stroker soon-ish. Hiding parts from the mrs since 2011. Build thread

  10. #9
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,553
    Disappointing but not surprising... see it a lot...

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  11. #10
    Pushing the limits..

    Status
    Offline
    Join Date
    Jan 2011
    Location
    Australia
    Posts
    1,314

    My Social Networking

    Add Sevv on Facebook
    wow , damn i thought i had issues... i hope your sort it out.. seb will be doing all that from me hehe... i can be smug about it too.. he will be doing the oil pump tensioner pick up rear main seal new 580ft clutch and well LSD box :D finally..

    why is it burning oil though i dont replace not a dropplet of oil on mine thank God.. its stays at the same level each time i check

  12. #11
    Sam_'s Avatar
    Down under

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Sydney, Australia
    Posts
    2,783
    Changed the plugs (BKR7Es) but it's still doing it. I went to give it some stick on a sliproad and had to let off straight away.

    I decided to checkout what the timing pull was up to...



    Not good. Then I logged again on the way home from getting some iso alcohol to clean the MAF:



    Mental numbers.

    At least the brakes are awesome I haven't done a logging session (need to setup a Windows XP vm again...) but that's next along with a MAF clean. I'm almost positive it's knock. Could it be a lambda?
    Handling mods++. HTA3582 stroker soon-ish. Hiding parts from the mrs since 2011. Build thread

  13. #12
    Welly's Avatar
    VX220 SC Driver :)

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Gloucestershire
    Posts
    10,695
    Thats some reasonable timing pull for sure dude. What RON fuel are you using out of interest?

    Avoid booting with figures like that.

    Is it mapped?
    ------------------------------------------------------------------------------------------
    "Marriage is like a coffin and each kid is another nail."
    Homer Simpson





  14. #13
    Welly's Avatar
    VX220 SC Driver :)

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Gloucestershire
    Posts
    10,695
    And its unlikely to be lambda related.
    ------------------------------------------------------------------------------------------
    "Marriage is like a coffin and each kid is another nail."
    Homer Simpson





  15. #14
    chaz20vt's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Aug 2012
    Posts
    425

    Re: Uh oh, knocking...

    I get high timing pull like that in.fact higher sometimes iv now put it Down to a crappy map on my car

  16. #15
    Sam_'s Avatar
    Down under

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Sydney, Australia
    Posts
    2,783
    Well it's never done it in the 18 months I've owned it, only in the last month or so.

    I went out for a curry with a few mates tonight and on the drive back, this:



    It was cooler tonight but still...

    I'll give the MAF (<12 months old) and AIT sensor a clean at the weekend, check for obvious vac/boost leaks and give it a proper scan/log.

    Don't worry, I've not been booting it with it like this. The noise of knocking sends shivers down my spine. I build a 1.6 n/a engine once and the CR worked out to be like 12:1 and the bloody thing would never stop pinking.

    Welly: I always use 98, either Shell or BP without fail. It's got a stage 1 map of some sort, unsure which but it runs 21psi and generally drives well, just recently is having issues. It's getting itself quite hot and bothered at times. Idle has been a bit off too.
    Handling mods++. HTA3582 stroker soon-ish. Hiding parts from the mrs since 2011. Build thread

  17. #16
    s3dave's Avatar
    TFSI Hybrid

    Status
    Offline
    Join Date
    Nov 2009
    Location
    west yorks
    Posts
    10,121
    where is that screen on the liquid gauge?...

  18. #17
    Sam_'s Avatar
    Down under

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Sydney, Australia
    Posts
    2,783
    Under "Graph items", last item (go up, rather than all the way down heh)
    Handling mods++. HTA3582 stroker soon-ish. Hiding parts from the mrs since 2011. Build thread

  19. #18
    s3dave's Avatar
    TFSI Hybrid

    Status
    Offline
    Join Date
    Nov 2009
    Location
    west yorks
    Posts
    10,121
    HA Ive never pressed it up i dont think... thanks

  20. #19
    Sam_'s Avatar
    Down under

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Sydney, Australia
    Posts
    2,783
    I always do it for oil temp, quicker way to get to it as its the last item, wait for it to hit 75-80 then nail it (although not at the moment :'( )
    Handling mods++. HTA3582 stroker soon-ish. Hiding parts from the mrs since 2011. Build thread

  21. #20
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,553
    Checked for oil in the throttle body and charge pipes yet?

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  22. #21
    Sam_'s Avatar
    Down under

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Sydney, Australia
    Posts
    2,783
    Yeah I did sorry. It was dry as a bone. The catch can must be helping...

    I also checked the oil when I changed the plugs and I'd not lost much, if anything.

    This morning's drive (it's cool again):

    Handling mods++. HTA3582 stroker soon-ish. Hiding parts from the mrs since 2011. Build thread

  23. #22
    StaceyS3's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Dec 2010
    Location
    Maldon, Essex
    Posts
    2,098

    Uh oh, knocking...

    Seems very related to your inlet temps mate, maybe WMi worth a punt
    Power & Torque 335bhp 285ftlb
    0-60 4.64 1/4 mile 13.02
    My GTX3071r Build Thread
    http://www.audi-sport.net/vb/a3-s3-f...ld-thread.html

  24. #23
    Sam_'s Avatar
    Down under

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Sydney, Australia
    Posts
    2,783
    It's odd though, it didn't do it last summer (which was hotter than now, still spring). Not sure about entering the WMI lottery. Is there a solid, easy to fit kit that doesn't piss out everywhere or ruin throttle bodies? I'll give the maf a clean and check a few things tomorrow like I say and go from there...
    Handling mods++. HTA3582 stroker soon-ish. Hiding parts from the mrs since 2011. Build thread

  25. #24
    Sam_'s Avatar
    Down under

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Sydney, Australia
    Posts
    2,783
    Didn't get a chance to do a scan or clean on the weekend but maybe tonight.

    I seem to have another issue, not sure if it's related but I get a very intermittent cut of all power for milliseconds sometimes, it's like the car stalls and then comes back to life. Only this morning on the way to work, it cut out completely. It doesn't seem like a normal stall, more like a complete loss of power but the key brings it back to life. It's only ever happened at idle though, never cut out while driving (fingers crossed!!).
    Handling mods++. HTA3582 stroker soon-ish. Hiding parts from the mrs since 2011. Build thread

  26. #25
    Sam_'s Avatar
    Down under

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Sydney, Australia
    Posts
    2,783
    Still getting this occasionally. I think the other issue of stalling now and then is caused by the crank sensor which arrived at work today, so might attempt it at the weekend.

    Here's a detailed pic of the plugs:



    Larger pic here: plugs.jpg

    Does it look like it's running lean?

    Possible failures?
    - Fuel pump slowly dying a death. It's not loud though?
    - EGT threw a code, 17863, but it's not come back today - I do have an exhaust leak (where the Milltek joins the cat) which apparently effects EGT? If the EGT sensor was duff, wouldn't it be rich? I got 24mpg from it on the last tank.
    - Could the crank sensor cause this as well? Cam sensor?

    Not measured block 020 but I should be able to this weekend if I can nick the mrs' macbook.
    Handling mods++. HTA3582 stroker soon-ish. Hiding parts from the mrs since 2011. Build thread

  27. #26
    Sam_'s Avatar
    Down under

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Sydney, Australia
    Posts
    2,783
    No ideas?
    Handling mods++. HTA3582 stroker soon-ish. Hiding parts from the mrs since 2011. Build thread

  28. #27
    s3dave's Avatar
    TFSI Hybrid

    Status
    Offline
    Join Date
    Nov 2009
    Location
    west yorks
    Posts
    10,121
    They look fine to me mate, just how they should be...

  29. #28
    Sam_'s Avatar
    Down under

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Sydney, Australia
    Posts
    2,783
    I can't understand what it can be then. It's definitely pinking/knocking now and then and it seems to be when the fuel system is asked to respond very quickly, i.e. dropping it to 2nd to clear a gap etc.

    It done it tonight on the way home, oil was hot, IATs were 25c odd and it wasn't a hot day really.

    I guess no ones had anything similar? Fuel pump?
    Handling mods++. HTA3582 stroker soon-ish. Hiding parts from the mrs since 2011. Build thread

  30. #29
    Sam_'s Avatar
    Down under

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Sydney, Australia
    Posts
    2,783
    I've been doing more reading. Is it possible that a cam sensor could cause this? Is the crank sensor used for timing or just during start up or are both essential for running? I have a new crank sensor here, could order a cam sensor too, if that's a likely cause.

    What would I log to indicate whether the fuel pump is shot? I'll check the hose to the FPR but I've got a feeling it's not that - it's silicone, not old, and that'd cause a constant issue I'd assume.
    Handling mods++. HTA3582 stroker soon-ish. Hiding parts from the mrs since 2011. Build thread

  31. #30
    Sam_'s Avatar
    Down under

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Sydney, Australia
    Posts
    2,783
    New * GENUINE * Audi A3 TT 3.2L Turbo 1.8L BDB Electronic Fuel Pump Assembly | eBay
    (think the pics wrong)
    Is it worth getting in preparation for BT (combined with an 044 when the time comes) and eliminating it now?

    Or could it be:
    GENUINE VW AUDI SEAT SKODA 1.8 2.0 IGNITION HALL SENDER SENSOR - 058 905 161 B | eBay

    It's not thrown a sensor code or anything but nor has it thrown one for anything else...
    Handling mods++. HTA3582 stroker soon-ish. Hiding parts from the mrs since 2011. Build thread

  32. #31
    Sam_'s Avatar
    Down under

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Sydney, Australia
    Posts
    2,783
    Checked all vacuum and n75 hoses. Nothing obvious

    Checked for boost spikes and the same old 1.5 bar peak (but also had no pinking today).

    I'll keep investigating.
    Handling mods++. HTA3582 stroker soon-ish. Hiding parts from the mrs since 2011. Build thread

  33. #32
    1st Gear

    Status
    Offline
    Join Date
    Jun 2011
    Location
    S.E. Melbourne/ Australia
    Posts
    146
    Hi Sam, are you able to do some logs of the AFR?
    I believe the blocks are 001 and 031 and post them up.
    Or alternately fit a fuel pressure gauge in line just before the injector rail and go for a spirited drive, preferably with a passenger so he can watch fuel pressure behavior.
    Fuel pressure should shift if on boost or overrun, in other words total fuel pressure is 3 bar + boost.
    Ross
    2000 Brilliant Black TT Quattro.
    2010 Daytona Grey TTRS.

  34. #33
    Sam_'s Avatar
    Down under

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Sydney, Australia
    Posts
    2,783
    Spa design boost and fuel pressure gauge on its way :-) spa make awesome kit.
    Handling mods++. HTA3582 stroker soon-ish. Hiding parts from the mrs since 2011. Build thread

  35. #34
    vrbob's Avatar
    Thats no Moon, Thats a space station!

    Status
    Offline
    Join Date
    Jun 2007
    Location
    Southampton
    Posts
    2,362
    if its fuel related could your injectors need a clean? as that a quick and easy thing to do.
    Audi S3 8L BAM 225 2002 - Ming Blue : Silver Heated Leather, Armrest, RNS-E - Bose, Alloy Mirrors, 18" RSTT`s, Sunroof, Cruise, AutoDim Mirror & Usual S3 Extras.
    Mods : Badger 5 Stg 2 Custom Map, FMIC, 3" DP & 200 Cell Cat, 007P, Jetex Filter & 80mm TIP & Heatshield, Complete LED Kit, Gen VW Aero Wipers, Full Powerflex Kit, R32 RARB, AP Shocks & Springs, 15mm Front & 20mm Rear Spacers, BB Uprated Actuator,
    N249 Delete & Catch Can, AP TVR 4Pot Brakes & DS2500`s, Sachs Carbon/Kevlar Clutch

  36. #35
    Sam_'s Avatar
    Down under

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Sydney, Australia
    Posts
    2,783
    I did them about 6 months ago but won't harm to do them again but I just think its something else. If the injectors were dirty it would effect it at other times too I'd say.
    Handling mods++. HTA3582 stroker soon-ish. Hiding parts from the mrs since 2011. Build thread

  37. #36
    vrbob's Avatar
    Thats no Moon, Thats a space station!

    Status
    Offline
    Join Date
    Jun 2007
    Location
    Southampton
    Posts
    2,362
    yeah your probably right but its worth checking plus you can give the FPR a good clean too just for good measure.

    Hope you solve it soon
    Audi S3 8L BAM 225 2002 - Ming Blue : Silver Heated Leather, Armrest, RNS-E - Bose, Alloy Mirrors, 18" RSTT`s, Sunroof, Cruise, AutoDim Mirror & Usual S3 Extras.
    Mods : Badger 5 Stg 2 Custom Map, FMIC, 3" DP & 200 Cell Cat, 007P, Jetex Filter & 80mm TIP & Heatshield, Complete LED Kit, Gen VW Aero Wipers, Full Powerflex Kit, R32 RARB, AP Shocks & Springs, 15mm Front & 20mm Rear Spacers, BB Uprated Actuator,
    N249 Delete & Catch Can, AP TVR 4Pot Brakes & DS2500`s, Sachs Carbon/Kevlar Clutch

  38. #37
    Sam_'s Avatar
    Down under

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Sydney, Australia
    Posts
    2,783
    Cheers dude, yeah I'll give them both a clean when I fit the fuel pressure gauge.
    Handling mods++. HTA3582 stroker soon-ish. Hiding parts from the mrs since 2011. Build thread

 

 

Similar Threads

  1. Knocking from the front during gentle braking ???
    By noodle in forum A3/S3 Forum (8L Chassis)
    Replies: 3
    Last Post: 27th January 2008, 22:29
  2. Knocking sound
    By recomdos in forum A3/S3 Forum (8L Chassis)
    Replies: 1
    Last Post: 23rd May 2004, 19:14
  3. (Rear?) Suspension Knock on S3
    By gdwood in forum A3/S3 Forum (8L Chassis)
    Replies: 1
    Last Post: 8th November 2003, 19:05
  4. Knocking Noise
    By L1ARR in forum A3/S3 Forum (8L Chassis)
    Replies: 1
    Last Post: 15th September 2003, 17:19
  5. What can knock a knock sensor?
    By MisterD in forum General Technical / How To
    Replies: 15
    Last Post: 20th May 2003, 13:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO