Monster MotorsportAH Fabrications
Results 1 to 8 of 8
  1. #1
    1st Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    Manchester
    Posts
    229

    wastegate, n75 question

    Since ive had my s3 its lost power and i compensated for this by adjusting the wastegate a while back, since then ive fitted a b5 tip, found a few boost leaks and done a full pcv delete with catch can, it ran great for a few days but it seems like its loosing power again, everytime i make it run well, a few days later its back to its usual self.
    1st gear is fine, but when accelerating in 2nd or 3rd the turbo sounds like its working overtime and the car isnt going like it should, it sounds like the turbo is going to explode, theres a loud low pitched hiss and also a high pitched hiss and it doesnt go like it should.
    So ive been thinking, the mods ive done and leaks ive found will the turbo be overboosting and the ecu compensating for this by the n75 valve? is this completely wrong or could it be true? is it worth backing the actuator off and giving it a go or will it just result in less power simples?

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Paradox1's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Aug 2011
    Location
    SoUf EaSt,Uk
    Posts
    1,829
    Sounds like a boost leak mate.its air escaping out of the system.double check that all hoses are done up tight and that there are not split or damaged hoses.I've had my fair share of boost leaks,I hear them a mile off lol
    Word!!!

    My A3/Martys Golf would smash that, and this guys £7000 GT9743 supercharged love machine.

  4. #3
    s3dave's Avatar
    TFSI Hybrid

    Status
    Offline
    Join Date
    Nov 2009
    Location
    west yorks
    Posts
    10,121
    You have to be careful putting extra preload on willy nilly, did you see what the actuator pressure is with the N75 unplugged..?

  5. #4
    1st Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    Manchester
    Posts
    229
    Ive been over all the pipes hence the pcv delete but I cant find anything, my mate is having words with someone with a smoke tester. It was about 6psi on gauge but I plugged the footpump into it yesterday and got 4psi but not sure if it was accurate

  6. #5
    s3dave's Avatar
    TFSI Hybrid

    Status
    Offline
    Join Date
    Nov 2009
    Location
    west yorks
    Posts
    10,121
    I have actually just changed my Actuator as it was leaking air, so a smoke test may find this?
    I got mine from Dan on here ....(beachbuggy)uprated... as the forge ones by all accounts are not very good...

  7. #6
    Dani_B19's Avatar
    Audi-sports own special child.

    Status
    Online
    Join Date
    Nov 2008
    Location
    Barnsley
    Posts
    7,233
    What one has Dan provided for you dave?
    Driving the most secretive S3 on ASN

  8. #7
    1st Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    Manchester
    Posts
    229
    should i be able to blow through the large connector that goes to the metal turbo outlet pipe? i would of thought this would be closed or does it close when needed?

  9. #8
    RIP S3dave

    Status
    Offline
    Join Date
    May 2004
    Location
    nr Glos
    Posts
    7,185
    smoke test for the win...
    leaky may well be revealed then...

    you should'nt be hearing hissing...
    **http://www.facebook.com/Badger5Ltd**

    NEW NEW NEW eShop now LIVE>
    www.badger5.biz

    Badger 5 Ltd, Queen Annes Gate, Oldends Lane, Stonehouse, Glos, GL10 2DG


    http://www.badger5.co.uk, Tel:01453822880
    bill@badger5.co.uk
    **NEW** Badger5 Section CLICK here>> http://www.audi-sport.net/vb/213-badger-5/

 

 

Similar Threads

  1. Another n75 question
    By Metro in forum A3/S3 Forum (8L Chassis)
    Replies: 3
    Last Post: 12th February 2012, 21:39
  2. N75 question...
    By warleydaddy in forum A3/S3 Forum (8L Chassis)
    Replies: 8
    Last Post: 9th February 2012, 09:04
  3. N75 question
    By AARON77 in forum A3/S3 Forum (8L Chassis)
    Replies: 7
    Last Post: 14th June 2011, 13:19
  4. quick N75 question
    By jay1601 in forum A3/S3 Forum (8L Chassis)
    Replies: 9
    Last Post: 23rd January 2011, 15:25
  5. N75 Question
    By QuottroA4 in forum Tuning
    Replies: 2
    Last Post: 6th November 2009, 17:39

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO