Volks AutosEM Tuning
Results 1 to 15 of 15
  1. #1
    Ryan_W's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Mar 2010
    Location
    Stamford
    Posts
    332

    Drivers Door and Boot Lights Not Working?

    Gents,

    Quick one for you.

    Just replaced all my bulbs for LEDs (looks great) but my drivers red warning and puddle lights won't work, nor will my boot lights... These didn't work before, so I'm not blaming the bulbs.

    The fuses look fine so have you got any ideas?

    Where are the switches which say when the door/boot is open?

    Hopefully get this sorted since I hate stupid little things like this!

    Cheers all in advance,

    Ryan
    '02 Audi S3 - 270bhp / 283lb ft - SOLD
    '08 BMW 135i - 306bhp / 295lb ft
    '12 VW Golf GTD 170 - 168bhp / 258lb ft


  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Ryan_W's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Mar 2010
    Location
    Stamford
    Posts
    332
    Sooo, after a night of research, I've read that it's the microswitch which is part of the rear wiper mech that is the most likely cause of the lighting issue in the boot.

    Anyone got any pics? I assume I've got to rush take the rear trim off and give it a good clean.

    As for the door lights, would this again be a microswitch? If so, where's it located?

    Cheers
    '02 Audi S3 - 270bhp / 283lb ft - SOLD
    '08 BMW 135i - 306bhp / 295lb ft
    '12 VW Golf GTD 170 - 168bhp / 258lb ft


  4. #3
    danger S3's Avatar
    2nd Gear

    Status
    Online
    Join Date
    Jun 2010
    Location
    Edinburgh, Scotland
    Posts
    355
    the boot lights are controlled by a wee switch in the latch thing on the botom of the boot lid, mine was well corroded because the rear washer had been leaking for ages and it just runs down over it, try giving it and the terminals a good clean up and see if it works, if your rear washer is leaking then you can get a repair kit with all the bits (main bits the wee brass pipe to the nozzle) which will fix it.

  5. #4
    Ryan_W's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Mar 2010
    Location
    Stamford
    Posts
    332
    Right, had another go at this today...

    Boot lights are now working, took all of 10 seconds to fix. I didn't take the boot plastic lining out, just prised it away from the boot with a screwdriver and gave the green connector a 'jab' with another screwdriver, hey presto, boots lights came on, happy days!

    Now, the drivers door red warning light and puddle lights are still not working..... Any ideas? Once these are fixed, my car is literally 100% as it should be!

    Any help would be much appreciated!

    Cheers,

    Ryan
    '02 Audi S3 - 270bhp / 283lb ft - SOLD
    '08 BMW 135i - 306bhp / 295lb ft
    '12 VW Golf GTD 170 - 168bhp / 258lb ft


  6. #5
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,370
    does the interior light come on as expected when you open the drivers door?

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  7. #6
    Ryan_W's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Mar 2010
    Location
    Stamford
    Posts
    332
    Yup, I've just been testing the microswitch and it's fine. When pushed in the interior lights go off and the DIS shows no open doors. When released, the lights come on (not the warning or puddle lights) and the DIS shows an open drivers door....

    Really not sure whats cracking. The bulbs are brand new LEDs, but the lights never worked before I changed over either...

    I've tested all the connections, but I'll try again......
    '02 Audi S3 - 270bhp / 283lb ft - SOLD
    '08 BMW 135i - 306bhp / 295lb ft
    '12 VW Golf GTD 170 - 168bhp / 258lb ft


  8. #7
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,370
    Ok so the door/footwell lights are all powered by a relay, which provides 12v to each lamp, but it supplies the passenger side too...

    Ground goes direct to the door switch which you've already ascertained is working fine.

    Check for the appropriate 12v and ground signals at the bulb holder?

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  9. #8
    Ryan_W's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Mar 2010
    Location
    Stamford
    Posts
    332
    Haven't got a multimeter at home... That's pretty much the final piece to the puzzle though. If the bulb holders aren't getting 12v, the doorcard will have to come off to try and hunt down the damaged wire (oh joy)... haha
    '02 Audi S3 - 270bhp / 283lb ft - SOLD
    '08 BMW 135i - 306bhp / 295lb ft
    '12 VW Golf GTD 170 - 168bhp / 258lb ft


  10. #9
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,370
    hmm, are both lamps in the door card? Footwell light in the A4 is under the dash.

    Seems theres a two pin multiplug in the door supplying those two lamps! Maybe its just disconnected?

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  11. #10
    Ryan_W's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Mar 2010
    Location
    Stamford
    Posts
    332
    Maybe, maybe... So doorcard off and see if anythings disconnected...

    Has anyone got a pic of what I need to look for?
    '02 Audi S3 - 270bhp / 283lb ft - SOLD
    '08 BMW 135i - 306bhp / 295lb ft
    '12 VW Golf GTD 170 - 168bhp / 258lb ft


  12. #11
    Ryan_W's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Mar 2010
    Location
    Stamford
    Posts
    332
    UPDATE:

    Boot lights are not working after I 'fixed' them with a thump...

    The red circle is what I jabbed with the screwdriver before which made the lights in the boot work, but now they're not.



    What else can I fettle with now the covers off to make them work again?

    Cheers
    '02 Audi S3 - 270bhp / 283lb ft - SOLD
    '08 BMW 135i - 306bhp / 295lb ft
    '12 VW Golf GTD 170 - 168bhp / 258lb ft


  13. #12
    danger S3's Avatar
    2nd Gear

    Status
    Online
    Join Date
    Jun 2010
    Location
    Edinburgh, Scotland
    Posts
    355
    the connector on mine that was corroded and stopping it from working was in here where the arrow is attached to the bit that sticks out and locks into the bottom


  14. #13
    Ryan_W's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Mar 2010
    Location
    Stamford
    Posts
    332
    Boot light now fixed (properly)...

    The microswitch connectors were fine, however, the actual plastic housing wouldn't keep together, so the connectors couldn't mate up correctly. Bit of superglue and its held tight together now, happy days.

    Switch housing with the white dot (centre of pic):



    The culprit switch:



    Now I've got to get the drivers door card off and see what's happening behind there.......
    '02 Audi S3 - 270bhp / 283lb ft - SOLD
    '08 BMW 135i - 306bhp / 295lb ft
    '12 VW Golf GTD 170 - 168bhp / 258lb ft


  15. #14
    spartacus68's Avatar
    Neutral

    Status
    Offline
    Join Date
    Jan 2012
    Location
    Aberdeenshire
    Posts
    56
    Got the same problem with mine - but on A4 Avant quattro. I stripped out the door card - but couldn't see anything obvious. Wiring looks fine. I traced it back as far as the connectors in the footwell on the passenger side. Multimeter to the door light shows it's not getting 12v, although it's getting a little juice as it was a fraction off zero. I'm sure the continuity of the wiring is fine, no chaffing. Interior light works fine and door open function on dash.

    Still no puddle light and door light on passenger door. The puddle light on the driver's side and all the other door lights work. Everything else works as it should. Sorry to muscle in on the thread - but my car's symptoms are almost the same. Any advice appreciated.
    Last edited by spartacus68; 1st September 2012 at 10:48.
    Is that with or without VAT?

    2001 B5 A4 2.5 TDI Avant quattro sport (155k)
    2003 A2 1.4 TDI SE (125k)
    1995 80 TDI SE Avant (175k) sold

  16. #15
    Reverse Gear

    Status
    Offline
    Join Date
    Apr 2012
    Posts
    3
    Hi,

    I've problem with boot lights. Last weekend I dived into it and checked the lock itself. When I removed the microswitch from the lock and manually pressed it, then I heared some clicking noise from boot. Is it something to do with center lock pump? Whats that in the center of trunk? Ideas? I've attached two pictures. The lock was removed when I took those. Also, I can't get this item removed from trunk, I unscrewed two bolts but it is there like nailed...


    13040015.jpg13040013.jpg

 

 

Similar Threads

  1. Red door lights and puddle lights not working?
    By mikemk4gti in forum A3/S3 Forum (8L Chassis)
    Replies: 4
    Last Post: 7th July 2012, 19:09
  2. Help with passenger side electric window and door light not working!
    By BarryM in forum Audi S4/A4/A4 Cab (B7 Chassis)
    Replies: 0
    Last Post: 18th September 2011, 15:22
  3. Boot Lights not working
    By barachello in forum A3/S3 Forum (8L Chassis)
    Replies: 5
    Last Post: 27th October 2010, 21:36
  4. Brake lights not working? and front fogs wont turn off?
    By VTI_EG_DAN in forum A3/S3 Forum (8L Chassis)
    Replies: 21
    Last Post: 27th February 2009, 18:34
  5. Rear door light not working
    By ang12el in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 4
    Last Post: 11th December 2007, 09:12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO