EM TuningJMB Retrofits
Results 1 to 8 of 8
Like Tree1Likes
  • 1 Post By musty

Thread: EPC light and engine check light

  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    8

    Thumbs up EPC light and engine check light

    Hi all hope someone can help?

    I started my s3 today but with a struggle and a big puff of smoke from the back and fuel smell, I moved the car and went to go back about 20 mins
    later the car wont start epc light and engine light flashing relays clicking, can't get vag com to talk with the ecu it won't connect. Checked fuses all good, checked connections to ecu seem fine. Any help would be appreciated

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    cjsuk's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Leeds
    Posts
    562
    Mine sometimes wont start and the epc light comes on (1.8t aum), I vagcom'd it and it says crank position sensor which I got the sensor but not fitted yet.

    Have you tried disconnecting the battery for 20 mins? Then re connect and try vagcom, if still no communication try your vagcom on someone elses car just to make sure its nothing to do with your lappy or cable. Or try someone elses vagcom on yours.

    If that checks out ok, I dunno poss ecu fried?

    Hope you get it sorted

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    8
    Quote Originally Posted by cjsuk View Post
    Mine sometimes wont start and the epc light comes on (1.8t aum), I vagcom'd it and it says crank position sensor which I got the sensor but not fitted yet.

    Have you tried disconnecting the battery for 20 mins? Then re connect and try vagcom, if still no communication try your vagcom on someone elses car just to make sure its nothing to do with your lappy or cable. Or try someone elses vagcom on yours.

    If that checks out ok, I dunno poss ecu fried?

    Hope you get it sorted
    Thanks for your reply, I did disconnect the battery for 10 min but no luck might try 20 min, vag com works on my other car so that not the problem.

    I have read else where could be crank sensor or as you said fried ecu from a short in the loom
    Cj_sat69 likes this.

  5. #4
    cjsuk's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Leeds
    Posts
    562
    Your next cheapst option then is the sensor but its an arse to replace, if after that you still have no joy, i would try asking some more advise on here or see an auto electricion.

  6. #5
    MrTackalakalaka's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2012
    Location
    Truro, Cornwall
    Posts
    426
    Happened to me before. Got the sensor changed by my local garage and all was well!! hope u get it sorted!

  7. #6
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    8
    Thanks for all the help, it was water in the ECU after the mrs washed it so just drying it out now hopefully i dont have get a new ECU

  8. #7
    cjsuk's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Leeds
    Posts
    562
    Quote Originally Posted by musty View Post
    Thanks for all the help, it was water in the ECU after the mrs washed it so just drying it out now hopefully i dont have get a new ECU
    wow water in the ecu? thats not good, not a place you want water lol. Let us know what happens.

  9. #8
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    8
    Quote Originally Posted by cjsuk View Post
    wow water in the ecu? thats not good, not a place you want water lol. Let us know what happens.
    RIP to the Ecu had to buy another one but all is good now

 

 

Similar Threads

  1. EPC and engine management light
    By itsmeagain in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 5
    Last Post: 12th February 2012, 13:42
  2. VAGcom and engine check light
    By Datsun in forum A3/S3 Forum (8L Chassis)
    Replies: 1
    Last Post: 3rd February 2012, 07:34
  3. Eggy smell and engine management light
    By baz1 in forum A3/S3/Sportback (8P Chassis)
    Replies: 25
    Last Post: 30th August 2009, 17:40
  4. Replies: 1
    Last Post: 17th August 2007, 23:10
  5. engine check light
    By audii in forum A4/S4 forum(B5 Chassis)
    Replies: 3
    Last Post: 17th August 2007, 17:23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO