Chris NottSky Insurance
Results 1 to 9 of 9
  1. #1
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    70

    Indicators acting up, only flashing down one side. Where to start?

    When pressing the hazard switch in the car only the indicators down the left side of the car flash, this is the same when I press the lock/unlock button on the key fob it does the same. However when using the stalk and indicating to go right it works fine down the right side.

    Anyone dealt with this? Am I right in saying this is a possible relay fault or hazard switch? It's been like this for a while and has been plugged into Vagcom various times but nothing shows up.

    Thanks

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    s3dave's Avatar
    TFSI Hybrid

    Status
    Offline
    Join Date
    Nov 2009
    Location
    west yorks
    Posts
    10,121
    fairly common fault on the hazard switch yes...

  4. #3
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    70
    Brill. Can I get one from GSF or am I best getting a genuine one?

  5. #4
    2nd Gear

    Status
    Offline
    Join Date
    May 2011
    Location
    Portsmouth
    Posts
    397
    Mine had this problem. New hazard switch sorted it :-) I used genuine parts but up to you, only a switch, it's not a big deal

  6. #5
    Alex C's Avatar
    6th Gear

    Status
    Online
    Join Date
    Jan 2010
    Location
    Lizard, Cornwall
    Posts
    2,603
    what happens if you indicate right and turn your hazards on?
    Alex S3 AMK
    Bilstein B8s, H&R Springs, Neuspeed ARBs, Genuine 18" BBS LMs & LCR Brembos

  7. #6
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    70
    Quote Originally Posted by Alex C View Post
    what happens if you indicate right and turn your hazards on?
    Back in 2 seconds

  8. #7
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    70
    With the indicator stalk pushed up (indicating right) and then pressing the Hazard switch it just cuts the indicating right command and only flashes left. You can hear a distinct clunk coming from hazard button when it cuts out the right signal, which to me points out that the problem.

    Thanks for the help

  9. #8
    Nilz's Avatar
    Defo worth the wait :)

    Status
    Offline
    Join Date
    Apr 2006
    Posts
    10,087
    Its the hazard relay, its an all in one unit, you will be able to replace it and its a main dealer part only.

    Was about £35 all in and takes about 15mins to replace.

  10. #9
    s3mad_dude's Avatar
    Noggies ruuuule!

    Status
    Offline
    Join Date
    Jan 2006
    Location
    Hampshire
    Posts
    462
    Yep you need a new hazard switch. Simple fix, If you have a facelift, remove the radio then undo the screws that hold the piano varnish surrounding the hazard switch. Then just plug in the new one :-)

 

 

Similar Threads

  1. Orange side indicators cheap
    By babyaudi in forum For Sale/Wanted - Audi Parts
    Replies: 0
    Last Post: 29th February 2012, 14:17
  2. Indicators constantly flashing!/ Esp light/climate/key fob opening,etc.etc
    By sabs46 in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 26
    Last Post: 21st July 2011, 18:54
  3. Indicators no longer flashing! On the M6 now!!
    By jimmp in forum A3/S3 Forum (8L Chassis)
    Replies: 4
    Last Post: 26th November 2010, 20:54
  4. Indicators not flashing as they should
    By Izzy1 in forum A4/S4 forum(B5 Chassis)
    Replies: 13
    Last Post: 24th November 2010, 14:41
  5. Indicators not flashing
    By James333 in forum A3/S3 Forum (8L Chassis)
    Replies: 5
    Last Post: 6th January 2008, 18:03

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO