Chris NottMonster Motorsport
Results 1 to 6 of 6
  1. #1
    4th Gear

    Status
    Online
    Join Date
    Feb 2012
    Posts
    722

    weird esp/tc lights issue

    Hi guys. was driving along with my esp and tc turned on and was conering a bit quick and the esp kicked in. then afyer i noticed that the esp and tc light were now on and i couldnt turn them off. does this normally happen or is there a possible ussue. i restarted the car and it hasnt been on since. any help would be good thanks. daz

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    s3mad_dude's Avatar
    Noggies ruuuule!

    Status
    Online
    Join Date
    Jan 2006
    Location
    Hampshire
    Posts
    453
    This has happened to me before....I think the car throws its toys out the pram. Restarting the car sorted it out and it's not happened since.

  4. #3
    Gops's Avatar
    6th gear @7000rpm

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Coventry
    Posts
    2,526
    Happened to me too. I've seen it happen on a mk5 golf too. Restarted the car just set it back to normal. Check it for faults just incase!
    Quote Originally Posted by <tuffty/> View Post
    its either mapped or broken...

  5. #4
    jcs356's Avatar
    Brum brum

    Status
    Offline
    Join Date
    Jun 2004
    Location
    Englandland
    Posts
    2,672
    I had it and it was either the longitudinal or lateral acceleration sensor playing up. Best scan it to find out exactly what.
    Unfortunately neither of these are cheap - over £100 & dealer only - but it is a DIY job to fit (either behind the steering column or glovebox depending upon model year).
    Jason
    2001 Nogaro S3 (daily driver)

    1958 replica Porsche 356 Speedster (summer posing)
    1997 Seat Cordoba SX 16v (track day toy) replacing (t)rusty 1994 Seat Ibiza GTi RIP

  6. #5
    4th Gear

    Status
    Online
    Join Date
    Feb 2012
    Posts
    722
    Well they havent been back on but i know only too well about the longitudinal sensor. my last s3 had a light up with this. took 3 different garages and 3 different sensors to find out it wasnt plugged in all the way. lol

  7. #6
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2010
    Posts
    498
    Mine will occasionally kick the TC on when cornering moderatly in the dry. I really don't understand it. Also, the ESP light comes on and stays on after a long motorway drive. Restarting clears it. Annoying but not the end of the world. Plus, I prefer it off, saves it kicking on for no reason.

 

 

Similar Threads

  1. weird misssfiring issue.
    By 4rings in forum A3/S3 Forum (8L Chassis)
    Replies: 1
    Last Post: 26th February 2012, 17:45
  2. Weird demister issue
    By butler2.8i in forum A3/S3 Forum (8L Chassis)
    Replies: 0
    Last Post: 1st November 2011, 18:18
  3. Weird S3 fuel economy issue
    By Jade S3 in forum A3/S3 Forum (8L Chassis)
    Replies: 12
    Last Post: 4th March 2011, 19:01
  4. Weird Temp Gauge issue
    By ghost.s3 in forum A3/S3 Forum (8L Chassis)
    Replies: 15
    Last Post: 2nd April 2010, 16:44
  5. Weird Handling Issue
    By 5ean in forum A3/S3 Forum (8L Chassis)
    Replies: 15
    Last Post: 9th June 2009, 13:56

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO