AH FabricationsMonster Motorsport
Results 1 to 7 of 7
  1. #1
    Neutral

    Status
    Offline
    Join Date
    Jan 2012
    Location
    ilkeston derbyshire
    Posts
    43

    Angry water pi@@ing from rad

    hi guys another one of the horror heating storys im having
    pulled up today noticed a trickle of water coming from under the car at front tells me rads gone it aint gushing out just a trickle anyways ive changed the thermostat a few weeks ago when i checked the top hose on the rad to the engine was hot. when i checked the hose from the thermostat housing its cold. expanstion bottle is hot temps reading 90 no higher.
    just cant understand why that pipe is cold
    i changed the coolant distribution housing this monday as it had a crack in it
    now im at my whits end
    i can see my a3 on ebay v soon if i cannot sort
    if anyone can help id be gratefull
    thankyou for your time
    jay

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    S3featesV9's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Dec 2010
    Location
    Oxford
    Posts
    1,030
    Tried flushing the rad? See if it's blocked?

    Where is it actually leaking from? Rad itself? Or the hose connection?
    MODS - Custom Code phase 1, 007p DV, various powerflex bushes, EBC grooved and drilled - red stuff pads, N249 deletion. Badger5 V2 80mm TIP. Scorpion backbox + custom centre section, LCR front splitter, Jetex Fr-08001, R32 rear ARB, Forged IE rifle drilled rods, 20mm rear & 15mm front spacers.

    TO DO - Coilovers, adjustable tie arms, DP/mani/decat, FMIC and new remap


  4. #3
    Neutral

    Status
    Offline
    Join Date
    Jan 2012
    Location
    ilkeston derbyshire
    Posts
    43

    Lightbulb

    unsure at mo had steam from top right of rad but the plastic stopping u see it i can see the hose that seems ok and no havnt flushed the rad but i shall tomorow just worried it was a dodgy thermostat i brought i never tested before fitting as a mate did it for me i watched tho make sure it went back together as we left the altonator on also leak is at bottom right of rad so seems its going down the rad (sorry about the spelling)

  5. #4
    S3featesV9's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Dec 2010
    Location
    Oxford
    Posts
    1,030
    Hmmm. Where you get the stat from?
    MODS - Custom Code phase 1, 007p DV, various powerflex bushes, EBC grooved and drilled - red stuff pads, N249 deletion. Badger5 V2 80mm TIP. Scorpion backbox + custom centre section, LCR front splitter, Jetex Fr-08001, R32 rear ARB, Forged IE rifle drilled rods, 20mm rear & 15mm front spacers.

    TO DO - Coilovers, adjustable tie arms, DP/mani/decat, FMIC and new remap


  6. #5
    Neutral

    Status
    Offline
    Join Date
    Jan 2012
    Location
    ilkeston derbyshire
    Posts
    43
    moto factors old one was rusted around the edge

  7. #6
    S3featesV9's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Dec 2010
    Location
    Oxford
    Posts
    1,030
    Ppl tend to have issues with non OEM Stats. Read through a few of the most recent thermostat threads. I haven't though, mines from ECP and it's fine so far.
    MODS - Custom Code phase 1, 007p DV, various powerflex bushes, EBC grooved and drilled - red stuff pads, N249 deletion. Badger5 V2 80mm TIP. Scorpion backbox + custom centre section, LCR front splitter, Jetex Fr-08001, R32 rear ARB, Forged IE rifle drilled rods, 20mm rear & 15mm front spacers.

    TO DO - Coilovers, adjustable tie arms, DP/mani/decat, FMIC and new remap


  8. #7
    Neutral

    Status
    Offline
    Join Date
    Jan 2012
    Location
    ilkeston derbyshire
    Posts
    43
    so tomorow im buying a new rad..Also i belive your right S3featesV9 with the thermostat being crap....
    Can i take the old one totally out or cut the center sping/metal bits leaving the outer-part out the aftermarket stat
    Or will this cause problems i aint botherd about heat in car had none for 6 months..this fix is just a temp thing until i can get old of a OEM stat and refit it ?

    Also brought and changing fan temp switch and the switch in the temp distribution housing on side of head
    any advice would be great doing it tomoz dinner
    thanks again
    :D

 

 

Similar Threads

  1. Rad Grills
    By PhilMill63 in forum Audi S4/A4/A4 Cab (B7 Chassis)
    Replies: 4
    Last Post: 9th February 2011, 15:53
  2. Anyone fitted a rad to their s3 ?
    By motfree in forum A3/S3 Forum (8L Chassis)
    Replies: 15
    Last Post: 5th December 2010, 16:58
  3. S3 rad ...
    By motfree in forum A3/S3 Forum (8L Chassis)
    Replies: 5
    Last Post: 29th November 2010, 22:43
  4. Please help :-( Rad leak
    By Kuzzie in forum A3/S3 Forum (8L Chassis)
    Replies: 16
    Last Post: 15th July 2010, 12:51

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO