Sky InsuranceMonster Motorsport
Results 1 to 23 of 23
  1. #1
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    34

    Just bought 2001 s3, looking for some help please!

    Hi all,

    Hope you're well. I've been reading threads on here in the build up to buying an S3 to get some ideas and help! Finally got hold of one on Saturday and was hoping to use some of your expertise if possible!

    Picked up the car from a garage near Manchester and all seemed well, good condition for age and bags of service history - does need a haldex service which I'm booking in and the garage were totally upfront about that.

    After doing a deal and getting taxed and tested, got on the road back down to London. The car drove fantastically well and I was really happy with my purchase... and still am really, but there are a couple of minor things that came up during the drive home.

    Firstly, after filling up with premium, and I did totally brim it, I rejoined the motorway and about half an hour later the yellow engine light came on. The next time I stopped I opened the petrol cap and closed it again as I read sometimes the pressue in the fuel tank can tell the engine it's running rich, but the light remains on. There are no performance indications of a problem, neither are there any smells/gases/smoke etc and the economy seems fine.

    The second thing is there is a very minor creaking noise which appears to be coming from the front of the car. It is most evident when at very low speeds - crawling around town at around 10-15 mph and specifically when pulling away, or slowing. It dosn't sound like an 'angry' noise, but is obviously something I'd like to get to the bottom of. My prediction is that its something to do with the struts as it isn't any better or worse when applying lock, so I don't think (hopefully) it is antyhing to do with the steering rack. (Just thought to add.. this seems to come on more when the car is warm and has been running for a while)

    Any help/similar scenario feedback from you guys and gals would be really, really appreciated!

    Oh, and if anyone knows a good place in South West London to get a Haldex Service done, and what to expect on price, I'd be really grateful too!

    Many thanks,

    Matt

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    jcs356's Avatar
    Brum brum

    Status
    Online
    Join Date
    Jun 2004
    Location
    Englandland
    Posts
    2,672
    Hi and welcome.

    I think you'll need to get the car scanned on VAG.COM / VCDS to identify what's causing your EML to come one.
    The creaking noise I'd say would be the front Anti-rollbar drop links. They are a reasonable DIY job to change, you just have to jack up the whole front of the car to do it (if you only jack one side the anti-rollbar will be twisted and you'll never get the link off).
    Jason
    2001 Nogaro S3 (daily driver)

    1958 replica Porsche 356 Speedster (summer posing)
    1997 Seat Cordoba SX 16v (track day toy) replacing (t)rusty 1994 Seat Ibiza GTi RIP

  4. #3
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    34
    Hi Jason,

    Thanks so much for that, really helpful. I'll look into getting a specialist to look at all three when I get the haldex done, hit a triple whammy! ANy suggestions on specialists to use that aren't dealer-priced?

    Thanks,

    Matt

  5. #4
    2nd Gear

    Status
    Offline
    Join Date
    Oct 2008
    Location
    Glasgow
    Posts
    430
    as said getting the car scanned using vag com will bring up any faults.

    The creaking may be the top mounts. I have just replaced these on my friends r32 golf with some 034 motorsport mounts and bearings. It could be worth getting the car fully checked over so that you know exactly where you are with it and any faults it has.

  6. #5
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    34
    Thanks Hektor, I think this is definitely the way forward. Know my way around an engine, but not too sure on suspension/steering mechanics as much. Just searching for an independent garage in and around South West London who would be happy to help.

    Matt.

  7. #6
    Erf
    1st Gear

    Status
    Offline
    Join Date
    Oct 2006
    Location
    Kingston
    Posts
    232
    Where abouts in South West London are you? I used gsf motor works in battersea for a full service on my recently purchased s3. Came in at over a grand. Also highly recommend just the ticket in new Malden. Not Audi specialists, but trustworthy guys.
    Silver 2002 S3 - Alloy Mirrors - RNS-E - Parrot MKI9200 - Beesting Ariel - Stealth Catch Can - S2000 Air Filter - R32 Rear ARB

    Oyster Grey 2008 A6 Avant S-Line 2.0TDI DPF

  8. #7
    1st Gear

    Status
    Offline
    Join Date
    May 2009
    Location
    Midlands
    Posts
    197
    Quote Originally Posted by Erf View Post
    Where abouts in South West London are you? I used gsf motor works in battersea for a full service on my recently purchased s3. Came in at over a grand. Also highly recommend just the ticket in new Malden. Not Audi specialists, but trustworthy guys.
    Full service over £1000!!! What did you have done???

  9. #8
    Jimgrim77's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Nov 2011
    Location
    Clevedon, Near Bristol
    Posts
    957
    Welcome Matt.

    As above...do the basic checks.

    Get it on the Ramps and take a look beneath too.

    Update and enquire again.

    Ming Blue S3, Stage 3 Hybrid Turbo, Custom Map, Bosch 480 injectors, Custom TIP, Forge FMIC, 3" Downpipe, 200 Cell Sport CAT, Full Stainless, XS Power Mani, 6 Paddle Clutch, Red silicone hoses, LCR Brembo's, Forge 007p, KW Suspension Kit, Green filter, THS Mounts, 11mm & 16mm spacers, H&R Anti-roll bars, RS6 18" alloys, Michelin PS3's, Red Dog Bone Mount, Neuspeed quickshift, Boost Gauge, Aero wipers, LCR splitter, Forge Tie-bars, LED bulbs, Armrest, Custom TT pedals.

  10. #9
    The Doctor's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Jul 2009
    Location
    Planet Earth
    Posts
    1,177
    Haldex can be done yourself - very easy with a set of axle stands if you have the right tool (HALDEX OIL FILTER TOOL T10066 VW R32 AUDI S3 - AUDI TT | eBay) and oil & filter (Genuine VW Golf - Haldex Oil & Filter | eBay).

    Replace oil every 20k miles, plus filter every 40k miles.

  11. #10
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    34
    Hi guys, definitely the awesome help I expected on here! Thanks so much.

    Its going into west4autos in chiswick on Friday for the haldex and diagnostic. Strangely the drop bars problem seems to be far less prominent now, perhaps it was a lack of use thing?

    Ill let you guys know what th outcome is on Friday. Erf, I'm in Putney, I'll check out your suggestions for any future work.

    Cheers all,

    Matt

  12. #11
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    34
    Hi guys,

    Update - Haldex done efficiently by west4autos in Chiswick, really nice guys. The EML was down to the Lambda sensor saying the circuit is open, so nothing too serious. I reckon this is related to the thermostat now, as i've noticed really crappy economy around town and the temp sensor never gets to 90 degrees when I'm movnig around quickly, motorways or a roads for example, and only reaches and stays at 90 when I'm sitting in traffic for ages etc. I'm thinking, therefore that the thermo is not spekaing to the ECU correctly and therefore keeping the circuit open and therefore affecting economy and of course the temp sensor in the dash.

    Speaking to west4 aghain for a quote on changing the thermo, but if anyone's got any suggestions as a quick fix, or anything to try before I spend more money that would be great. I'm considering disconnecting the battery to do a 'hard re-set' of the ECU but wondering if this is even worth it.

    Cheers,

    Matt

  13. #12
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    70
    My car temperature wise was doing very similar to yours S3lvo, so I bought a new thermostat to throw in and turned out I didn't even have one in there in the first place! But strangely it's quite common they seize open and allow the coolant to continually flow (therefore not getting to operating temperature)
    As soon as I changed the stat it was hitting 90 and staying there.
    Pain in the ass job, especially that bottom bolt.

    Hope this helps

  14. #13
    Gops's Avatar
    6th gear @7000rpm

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Coventry
    Posts
    2,533
    Temp sender? I got mine for 27 quidish I think and might be a fix if it's not reading right. 15 min job to change and make sure you get the seal and clip too!
    Quote Originally Posted by <tuffty/> View Post
    its either mapped or broken...

  15. #14
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    34
    Thanks to both of you. I wonder whether it's worth doing the temp sender first... and see if that solves it. My garage are quoting me £175 quid for the change, seems a bit steep considering how quick the job is with the right tools! I'd do it myself, but living in london I don't have a drive or the right tools with me... might go back to my mum and dads and use theirs!!

  16. #15
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    70
    Thermostat cost me £6 and took me just under an hour to change purely because of access, there is a guide somewhere on the forum.
    The temp sensor isn't hard to change at all, just make sure you get a genuine sensor as the ones from Euro Car Parts etc tend to fail in a good few months, there is also a guide for replacing the sensor.

    £175 sounds a bit steep to me

    Some guides say you have to remove the alternator to gain access to the thermostat housing but there is no need if you have the right tools

    My money is on the thermostat, as we both had the same problem.

  17. #16
    Gops's Avatar
    6th gear @7000rpm

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Coventry
    Posts
    2,533
    Worth trying the temp sender if thermostat doesn't fix! Takes 15 mins and is easy lol
    Quote Originally Posted by <tuffty/> View Post
    its either mapped or broken...

  18. #17
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    34
    Hello all!

    Update for you once more! Got the car abck on the Vag Com, and checked a few bits and bobs. Went down the temp sender switch route - Thank you Gops - the dahs reading goes straight to 90 degrees when warm and stays there now and also replaced the Lambda sensor which has got rid of the EML and will hopefully sort out the economy as well as nothing will now be telling the choke to let more fuel into the system. Will only know this when I've driven around a bit, but off to Bournemouth this weekend I think so that should give me a good indication!

    Thanks for your help again guys - loving my S3!!

    Matt

  19. #18
    6th Gear

    Status
    Offline
    Join Date
    Feb 2009
    Location
    Aberdeen
    Posts
    2,523
    Does it look something like this, Matt



    Should give you an idea of wheels, if you want to stay OEM.

    Hope you have better luck with her than I did, and sounds like the big issues have been sorted so you're free to just enjoy the car now.
    Hunt is over

    1st Audi - 2001 Ming Blue 8L S3 210
    2nd Audi - 2008 Black 8P2 S3 3dr
    and now - 2007 Daytona Grey B7 RS4 saloon

  20. #19
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    34
    Nice mate.... 'that's my Car!'

    Like the wheels a lot... Going to be thinking about changing at some point. Do really like bbs as well though. Hmmm!

  21. #20
    Gops's Avatar
    6th gear @7000rpm

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Coventry
    Posts
    2,533
    Nice to see it work mate enjoy!
    Quote Originally Posted by <tuffty/> View Post
    its either mapped or broken...

  22. #21
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    34
    Update! Sadly, although the temp sender switch and lambda seem to have sorted out my economy, which is now really good it seems.. the dash reading still drops quite a lot when on the motorway etc. In with Audi today getting recall of coils done so asked them to change the themo while they're mincing around in my bay, so hopefully that'll do it! Gonna start a new thread re oil leaks too to get opinions. Audi are checking that for me too today, got a slight drip, really small patch under the front of the car when standing overnight. The car is driving absolutely fantastically though, and looks daaaaaaaamn pretty

  23. #22
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    34
    Oil leak from the Rocker Cover Gasket.... PHEW!!

    Will get that sorted pretty easily.

    Next up - New timing belt and Water Pump - New Thermostat - New Rear Discs and Pads - Brake Fluid Service........... then can possibly start looking at a re-map!!

  24. #23
    6th Gear

    Status
    Offline
    Join Date
    Feb 2009
    Location
    Aberdeen
    Posts
    2,523
    Quote Originally Posted by S3lvo View Post
    Oil leak from the Rocker Cover Gasket.... PHEW!!

    Will get that sorted pretty easily.

    Next up - New timing belt and Water Pump - New Thermostat - New Rear Discs and Pads - Brake Fluid Service........... then can possibly start looking at a re-map!!
    I had the car in Audi twice (once when they noted the oil leak, and later for the ticking again, neither time could they trace the source. Aberdeen Audi = useless!

    Good to hear you're getting everything sorted though, should end up being a pretty sweet car.

    Only reason I didn't get BBS is because insurance said that after market wheels made it a "hot hatch 2" which they wouldn't insure me on, so got OEM wheels and they couldn't say anything.
    Hunt is over

    1st Audi - 2001 Ming Blue 8L S3 210
    2nd Audi - 2008 Black 8P2 S3 3dr
    and now - 2007 Daytona Grey B7 RS4 saloon

 

 

Similar Threads

  1. Just bought a .......
    By johnlondonw3 in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 5
    Last Post: 18th December 2006, 20:49
  2. Just bought a 2001 S3, need a little info..
    By giorgos_cupra in forum A3/S3 Forum (8L Chassis)
    Replies: 9
    Last Post: 30th June 2005, 13:41
  3. Are pre 2001 door cards the same as >2001 in a 3dr
    By kazino21 in forum A3/S3 Forum (8L Chassis)
    Replies: 0
    Last Post: 2nd June 2004, 10:12
  4. Just bought an 2001 S4, have some questions...
    By samuel_adam in forum A4/S4 forum(B5 Chassis)
    Replies: 1
    Last Post: 1st May 2004, 20:30
  5. Anyone here bought 2001 S3 (T80CAR) recently?
    By scooter in forum A3/S3 Forum (8L Chassis)
    Replies: 15
    Last Post: 19th September 2003, 13:08

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO