Monster MotorsportChris Nott
Results 1 to 32 of 32
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    14

    car struggles at 3000rpm

    can any1 help me ive upgraded my turbo to a garret and have had problems since i got it back. Was told to put a boost controller on it so i got the aem tru boost.

    it will go past the 3000rpm but i have to go real slow, but if u plant the pedal it just chokes itself

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,018
    Ok... define upgraded and what car/engine? specs of the build?... can't just bolt on a Garrett as you probably know...

    Welcome to ASN

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    14
    ive got the garret gt28r with a bigger intercooler. ive also fitted genesis 550cc injectors, bigger fuel pump, aem piggyback ecu, aem tru boost, stainless steel exhaust from manifold to back box.

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    14
    its a audi a3 1.8t agu 8l w reg

  6. #5
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,018
    Has it been mapped on a dyno or have you just bolted this lot together?

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  7. #6
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    14
    been on the road twice first time when i got it all fitted and thats when it would not go by3000rpm then i got the tru boost done a week ago and it chokes at 3000rpm but as i said i have to take ma time and then i can get more revs but if i floor the pedal it coughs and bangs

  8. #7
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,018
    well... I suspect then that it needs mapping as the fuelling sounds out... AGU's aren't wideband so need to be mapped properly... with this piggy back ecu thing I assume you have gone MAF less?

    Do not drive it blind to AFR... you have made a lot of changes... I wouldn't be using any boost either so run on actuator pressure...

    Your car really needs to be going on a dyno where you can load it up and set the AFR properly... not familiar with the AEM stuff but assume it can be done through a connected laptop and appropriate software

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  9. #8
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    14
    its been mapped twice now could it be the standered ignition coil or the standered air mass meter.

    im not sure wat u mean by Do not drive it blind to AFR... New to the tuning scene and not sure wat it means

  10. #9
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,018
    What I meant was you need to know what your fuelling is doing...

    TBH mate with out logging the car on a dyno (as you are running a non standard ECU) then its difficult to say what is up... it could be ignition, fuelling or something else... 3000rpm is close to the onset of boost on a GT28r but not sure your issue can be diagnosed without it going on a dyno at a specialist mate...

    Std ECU's at least can be logged... no doubt the AEM can be too but without a wideband lambda you are not going to know what the fuel is doing...

    Where abouts are you based?

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  11. #10
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    14
    im based in ayrshie scotland. im not sure if i should just take it back to the tunner and tell him im not happy with the map he has done on it.

    many thanks for ur help.

  12. #11
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,018
    No worries mate... if its playing up then yes your best bet is to take it back to the tuner.... was it your tuner that suggested you get a boost controller? how did they map it for boost prior to this? Are you trying to run more boost than it was mapped for?

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  13. #12
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    14
    it was the tuner that suggested it and im not sure how he did it b4 i got it. i dont know how to work the boost contoller so i cant turn it down

  14. #13
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,018
    Humm... was the car running ok before you fitted the boost controller? do you have a boost gauge? what boost were you running before and after?

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  15. #14
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    14
    its made the car run better as i could not get by 3000rpm b4 i put it on and now it struggles to get by that point if u r driving fast

  16. #15
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,018
    So... your tuner mapped the car but it wouldn't go beyond 3000rpm?? then he told you to fit a boost controller to fix the problem and you don't know what boost you are running?

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  17. #16
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    14
    thats sounds about rite. will check the print out of the rolling road and see if its on that

  18. #17
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,018
    Wow!......

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  19. #18
    nwhiteley's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2006
    Location
    Howfen (its in Bolton)
    Posts
    194
    Is he a professional tuner, ie he has a tuning company, or is it just a hobby for him?

    Are there any warning lights on the dash?
    Have you had it scanned for faults?
    2007 A4 2.0TFSI S-LINE

  20. #19
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    14
    triple h tuning in irvine ayrshire. has own garage and website. nothing has come up on dash but i think he said the air mass but its a new 1 thats on it

  21. #20
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,018
    Fitting a turbo like the GT28r would need a VR6 housing for an AGU MAF sensor and the map scaled to cope... I have no idea how the AEM integrates but if its controlling fuelling etc as the AGU does through the MAF then thats gonna be an issue...

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  22. #21
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,018
    What model is the AEM ECU?

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  23. #22
    nwhiteley's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2006
    Location
    Howfen (its in Bolton)
    Posts
    194
    If he reckons its the MAF, just unplug it and take it for a spin, if it runs better, it needs a new MAF and/or housing, if not, look elsewhere.

    Or, does it not work like that with a BT conversion?
    2007 A4 2.0TFSI S-LINE

  24. #23
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,018
    AGU (and therefore I would assume the piggy back ECU) uses the MAF for everything... unplugging it doesn't work the same as cars with ME7 ECU's...

    Pulling the MAF on a normal AGU pretty much disables the car...

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  25. #24
    nwhiteley's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2006
    Location
    Howfen (its in Bolton)
    Posts
    194
    Quote Originally Posted by <tuffty/> View Post
    AGU (and therefore I would assume the piggy back ECU) uses the MAF for everything... unplugging it doesn't work the same as cars with ME7 ECU's...

    Pulling the MAF on a normal AGU pretty much disables the car...

    <tuffty/>
    Ah well, you learn something new every day. Sorry to the OP if i lead you on a wild goose chase.
    2007 A4 2.0TFSI S-LINE

  26. #25
    Neutral

    Status
    Offline
    Join Date
    Jun 2010
    Location
    warwickshire
    Posts
    93
    sorry to jump in but have you removed the n75 valve then if running a manaul boost controller??, was this set up the tuners idea?, And why are you using a piggy back ecu ??

  27. #26
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    14
    Quote Originally Posted by <tuffty/> View Post
    What model is the AEM ECU?

    <tuffty/>
    aem f/ic ecu system i have

  28. #27
    Welly's Avatar
    Testing dodgy Chinese gear...

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Gloucestershire
    Posts
    10,680
    This whole thing is utterly shocking from start to finish frankly. What sort of professional would allow a car out with a customer popping, farting, not running on boost, with what appears to be no fuelling control at all?

    As Tuffty said, pull the plug on the MAF on an AGU and it will not have a clue what is going on.

    I would be getting it to the nearest place that knows VAGs, and knows what they are doing, pronto.

    I do feel for you if I'm being honest, as it sounds like you have acted on some very bad advice.

    The ECU fitted to the car could be by the looks of things the F/IC 6 or 8. Both should really have the capability of running your gear if et up right, BUT, I must say it does look like these are more commonly used on turbocharged VTEC engines as opposed to out of the box turbo engines.
    ------------------------------------------------------------------------------------------
    "Marriage is like a coffin and each kid is another nail."
    Homer Simpson

    Quote Originally Posted by Prawn View Post
    Wellyboots, you are quite literally my most favourite pikey in the entire world




  29. #28
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    14
    took the car to the tuner today and he has told me that on the computer the maf kept say error but the thing is ive just replaced it a year ago. does this mean its a wiring fault on the maf

  30. #29
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    14
    also unplugged the maf and it still runs and has the same fault

  31. #30
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,018
    Quote Originally Posted by Andrew Mcculloch View Post
    took the car to the tuner today and he has told me that on the computer the maf kept say error but the thing is ive just replaced it a year ago. does this mean its a wiring fault on the maf
    MAF's don't last... I changed 4 in a year before now... seems really hit and miss... really can't comment on the wiring as you install is bespoke... did you do it? was it the tuner who did the conversion?

    If it was you then I would be checking your wiring just to eliminate it as an issue... assuming the software suggests its the MAF then its plausible...

    Quote Originally Posted by Andrew Mcculloch View Post
    also unplugged the maf and it still runs and has the same fault
    Well... seeing as this is all non std then I don't really know for sure but the fact the engine runs the same with it connected and disconnected then it would suggest this could be a potential cause...

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  32. #31
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    14
    its was a different garage that fitted the kit. but they ripped me off took over 3months to get ma car back off them and itook it to the tuner im using the now and he got the car running as i got it back a non runner. will try a new maf the morra and if not i guess its the wiring

  33. #32
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,018
    Good luck bud....

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

 

 

Similar Threads

  1. car shudders on full throttle and struggles to build up revs
    By Neesh in forum A3/S3 Forum (8L Chassis)
    Replies: 9
    Last Post: 15th May 2010, 22:06
  2. Car losing power - limited to 3000rpm
    By Monsoon in forum A3/S3/Sportback (8P Chassis)
    Replies: 18
    Last Post: 14th March 2008, 09:47
  3. Noise at 3000RPM
    By Jack D in forum A3/S3/Sportback (8P Chassis)
    Replies: 3
    Last Post: 25th January 2007, 14:22
  4. Stutter at 3000RPM - Chipped S3
    By DamoS3Q in forum A3/S3 Forum (8L Chassis)
    Replies: 27
    Last Post: 27th December 2004, 18:51
  5. decreasing lag before 3000rpm
    By gburgess in forum A3/S3 Forum (8L Chassis)
    Replies: 11
    Last Post: 20th September 2003, 12:12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO