Monster MotorsportVolks Autos
Results 1 to 4 of 4
  1. #1
    1st Gear

    Status
    Offline
    Join Date
    Jan 2011
    Location
    Glasgow
    Posts
    233

    S3 rear wiper noise (video)

    My Audi S3 since the day i've had it has always made this noise when using the wiper. The blade seems to hard pressed on the window causes this awful noise... every single time its used it does it unless its totally covred in screen wash! Ive replaced the motor as it broke a few months ago and the blades been changed.

    Any idea what i can do?

    Video: S3 wiper - YouTube

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    fingermouse's Avatar
    thats me

    Status
    Offline
    Join Date
    Sep 2004
    Location
    west yorkshire
    Posts
    3,762
    What blade did you fit? Ive seen this happen with cheap replacements.

    I always stick to Bosch.

    Could always fit a polo arm and a aero wiper
    red to red black to black blue to bits

  4. #3
    1st Gear

    Status
    Offline
    Join Date
    Jan 2011
    Location
    Glasgow
    Posts
    233
    Quote Originally Posted by fingermouse View Post
    What blade did you fit? Ive seen this happen with cheap replacements. I always stick to Bosch. Could always fit a polo arm and a aero wiper
    It's a Bosch blade. The blade before was doing the exact same thing. Can you put aero blade on rear standard arm?
    Last edited by Greig300; 9th February 2012 at 12:56.

  5. #4
    fingermouse's Avatar
    thats me

    Status
    Offline
    Join Date
    Sep 2004
    Location
    west yorkshire
    Posts
    3,762
    think you can get one but not bosch,

    A polo arm and cover isn`t much £20 ish iirc its 8 years since I changed mine
    red to red black to black blue to bits

 

 

Similar Threads

  1. Weird tut noise on idle? Tdi 2.0(video uploaded)
    By aterro in forum A3/S3/Sportback (8P Chassis)
    Replies: 13
    Last Post: 26th September 2011, 22:24
  2. Haldex noise (VIDEO)
    By Greig300 in forum A3/S3 Forum (8L Chassis)
    Replies: 8
    Last Post: 28th August 2011, 18:17
  3. S3 making strange noise VIDEO included!
    By AudiS3Quattro in forum A3/S3 Forum (8L Chassis)
    Replies: 6
    Last Post: 10th May 2011, 20:56
  4. Noise from engine, Video attached.
    By johal87 in forum A3/S3/Sportback (8P Chassis)
    Replies: 10
    Last Post: 17th January 2011, 11:59
  5. Strange, Annoying noise (video enclosed) Please Help.
    By Audime in forum A6/S6/Allroad forum (C5 Chassis)
    Replies: 1
    Last Post: 9th June 2010, 15:51

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO