EM TuningMonster Motorsport
Results 1 to 6 of 6
  1. #1
    MrTackalakalaka's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2012
    Location
    Truro, Cornwall
    Posts
    426

    Just cant work out what the problem is!

    Hello everyone

    Ive been having problems with my fuel gauge on my 2000 S3........

    I will fill my car right up to the brim and everytime, without fail the fuel light will come on and the gauge will read empty. The gauge and light will remain the same until i have done 100 miles approx (changes everytime) then it will normally go to a full tank, the light will also go off and the gauge stay there until ive got about a quarter of a tank left and it will drop to a quarter of a tank and wont go any lower, even if i run out of fuel.

    I have fitted a new fuel tank unit.......that didnt work!

    I then did a bit of research and found that a common fault is the cluster display......the LCD screen would have lines through it, the speedo and other gauges would also become faulty/incorrect. My LCD screen had lines through it but i wasnt sure about the other gauges.......anyhow I sent my cluster display off to BBA-Reman as I thought i might as well get the LCD screen replaced and see if there are any other faults.
    Unfortunately they said there was nothing wrong with the fuel gauge on the unit but AT LEAST I have a nice shiney LCD screen that i can read now! haha

    Now im back to square one!!

    Anyone have any ideas with what could be wrong?

    Thanks
    Scott

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    S3 Paul's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Oct 2006
    Posts
    2,764
    By fuel tank unit do you mean the whole thing that sits in the tank? ( got to under the rear seat of the car )?
    I though the level sensor was in there? Is the breather to the tank open and clear? i only ask this as a woman i know has a golf 4motion that had issues with the gauge reading full and her only being able to half fill it because the tank basicaly needed to burp.
    Noggy Blue 2001 S3

    I ask questions because i change my mind so much. If i ask questions you have already covered... just leave it be?

  4. #3
    MrTackalakalaka's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2012
    Location
    Truro, Cornwall
    Posts
    426
    Quote Originally Posted by S3 Paul View Post
    By fuel tank unit do you mean the whole thing that sits in the tank? ( got to under the rear seat of the car )?
    I though the level sensor was in there? Is the breather to the tank open and clear? i only ask this as a woman i know has a golf 4motion that had issues with the gauge reading full and her only being able to half fill it because the tank basicaly needed to burp.
    Hello

    Yes it was under the rear passenger seat. Hmmm thats interesting. Im not sure, will have to look

  5. #4
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,350
    sounds like a faulty tank level sensor to me

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  6. #5
    S3 Paul's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Oct 2006
    Posts
    2,764
    Mine got stuck once , But after changing the pump ( inside the unit with the sender on) its been fine
    Noggy Blue 2001 S3

    I ask questions because i change my mind so much. If i ask questions you have already covered... just leave it be?

  7. #6
    Alais DJA's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Southampton
    Posts
    559
    Fuel pump lag - there was a similar issue with my mates 1.8t golf.

    Uprated the pump, new sensor, and fuel filter. Dumped a bottle of red-x in it. Perfect ever since

    Marcus

 

 

Similar Threads

  1. Work on the S3 problem free until....
    By jdas03 in forum A3/S3 Forum (8L Chassis)
    Replies: 7
    Last Post: 9th September 2010, 21:59
  2. Poseidon Infosoft: Genuine Work at Home,Genuine Data Entry Work
    By tf2010r270 in forum The Welcome Section
    Replies: 0
    Last Post: 14th July 2010, 07:50
  3. Problem at work....
    By jb0o in forum Rants & Raves
    Replies: 18
    Last Post: 6th January 2010, 14:24
  4. Headlight washer jets dont work, what could be the problem?
    By VTI_EG_DAN in forum A3/S3 Forum (8L Chassis)
    Replies: 6
    Last Post: 25th March 2009, 10:21
  5. Having problem getting USB cable to work with VAG.com
    By Rev-head in forum VCDS (formerly VAG-COM) forum
    Replies: 34
    Last Post: 14th August 2007, 17:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO