Chris NottJMB Retrofits
Results 1 to 5 of 5

Thread: New Thermostat

  1. #1
    3rd Gear

    Status
    Online
    Join Date
    Apr 2011
    Location
    Dublin, Ireland
    Posts
    612

    New Thermostat

    Was out driving this evening and the engine temp would not go higher than 70deg. What do you think, dodgy stat.
    B5 v1 Tip, B5 Exhaust Manifold, Beach Buggy Hybrid, Pipewerx D.P and cat bypass, Miltek resonated cat back, AH Fabs v2 Intercooler, S2000 Filter, 83mm 9.5:1 CP Pistons, Brute Rods, Bosch 550cc Injectors, Oil Catch can, N249 delete, B5 Phenolic Gasket, Devils Own Water Meth Kit, Forge baffled sump.
    H&R Springs, Koni FSD Shocks, s3dave's rear tie bars, R32 ARB's, LCR Brembo's, 18" ttrs alloys, replaced all suspension bushes, 15/20mm spacers front/rear, Vibratechnics Engine Mounts.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Broken Byzan's Avatar
    Photographic Moderator

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Cardiff, United Kingdom
    Posts
    12,506

    My Social Networking

    Follow Broken Byzan On Twitter Add Broken Byzan on Facebook Add Broken Byzan on Google+ Visit Broken Byzan's Youtube Channel
    yep

  4. #3
    S3featesV9's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Dec 2010
    Location
    Oxford
    Posts
    1,030
    Exact same issue on mine. New stat fixed it
    MODS - Custom Code phase 1, 007p DV, various powerflex bushes, EBC grooved and drilled - red stuff pads, N249 deletion. Badger5 V2 80mm TIP. Scorpion backbox + custom centre section, LCR front splitter, Jetex Fr-08001, R32 rear ARB, Forged IE rifle drilled rods, 20mm rear & 15mm front spacers.

    TO DO - Coilovers, adjustable tie arms, DP/mani/decat, FMIC and new remap


  5. #4
    Steveo_A3_1.8t's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Mar 2009
    Location
    Great Wakering, Southend
    Posts
    196
    Quote Originally Posted by S3featesV9 View Post
    Exact same issue on mine. New stat fixed it
    Agreed, fitted one couple of weeks back as mine was doing exact same thing and fixed it.

  6. #5
    s3 addict's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Location
    Swadlincote, United Kingdom
    Posts
    18
    I had the same issue, the temp even went down as I drove. New Thermostat fixed it, pretty easy to fit.

 

 

Similar Threads

  1. thermostat ?
    By hilly in forum A3/S3 Forum (8L Chassis)
    Replies: 10
    Last Post: 10th January 2011, 09:35
  2. Thermostat
    By michaelspirou in forum A3/S3 Forum (8L Chassis)
    Replies: 1
    Last Post: 5th June 2010, 18:30
  3. A3 1.8T Thermostat!
    By AudiiduA in forum A3/S3 Forum (8L Chassis)
    Replies: 32
    Last Post: 27th February 2010, 20:31
  4. where is the thermostat?!!
    By edward_harris in forum A3/S3 Forum (8L Chassis)
    Replies: 1
    Last Post: 28th January 2008, 13:45
  5. Thermostat??
    By a3daveo in forum A3/S3 Forum (8L Chassis)
    Replies: 2
    Last Post: 27th November 2007, 13:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO