Badger5Sky Insurance
Results 1 to 8 of 8
  1. #1
    Bignick's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2008
    Location
    Kent
    Posts
    165

    Oil warning light

    I've changed my sump and put new oil pick up pipe on 3-4 wks ago, ive had the warning light come on a few times just as ive pulled into my road recently, i have checked levels and they are fine. is it likely to be a dodgey sender or is my oil pump going to want changing? i dont have access to VAG.com, and last night on my way back from a mates house the light came on 6-7 times i noticed it seemed to happen at low rpm. any suggestions would be appreciated ?
    The light that burns twice as bright , burns half as long.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    8,424
    could be the sensor
    are you geting the big oil light in the dis
    or the small check light ?
    red or yellow

  4. #3
    Bignick's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2008
    Location
    Kent
    Posts
    165
    Its the big one that screams at you, its red and fills the whole screen
    The light that burns twice as bright , burns half as long.

  5. #4
    patTTpoa's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Oct 2011
    Location
    Devon
    Posts
    793
    I'd check the wiring that goes down the back of the engine.
    Many peeps change the loom due to misfire (coils) but can also bring on the oil sensor (big oil can) on the DIS

    Pat






  6. #5
    sideways steve's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Dec 2011
    Location
    Paisley, Scotland
    Posts
    344
    If i had gone to the bother of changing the sump and the pickup I would certainly have stuck a new pump on it whilst in there. Was there any particular reason you didnt fit a pump whilst it was all apart ?

  7. #6
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    8,424
    thats the low oil preasure warning
    id say dont drive it till you find out whats up
    check the connection to the sensor
    if thats ok sump off check if the oil pickup pipe is blocked
    if it is and you keep driveing it its gona cost £££££££££££££ when it goes turbo etc etc

  8. #7
    Neutral

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Hull
    Posts
    89
    Hi
    i Had this problem on my s3, it is the oil presure warning light, my oil pick up pipe in the sump had a blockage. for what its worth id definatly take the sump off and have check it hasnt got blocked.

    im not a mechanic so not sure what other factors may cause the oil pressure to fail....im assuming you put new oil in when you changed the sump...was it good quality oil ? right grade etc etc,

    but as said already id strongly advise not to drive it until you have it sorted

    hope you get it sorted

    dom

  9. #8
    Bignick's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2008
    Location
    Kent
    Posts
    165
    Quick update, the problem turned out to be the sensor, replaced it and no more warnings. The reason the pump was not changed was, funds.
    The light that burns twice as bright , burns half as long.

 

 

Similar Threads

  1. Oil Warning Light / Coolant Warning Light / Coolant Leak
    By KV72 in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 3
    Last Post: 27th September 2010, 20:32
  2. Oil Warning Light
    By J1 MBO in forum A3/S3 Forum (8L Chassis)
    Replies: 0
    Last Post: 25th August 2010, 15:10
  3. Oil warning light on?
    By sprally in forum A3/S3 Forum (8L Chassis)
    Replies: 5
    Last Post: 12th May 2010, 02:58
  4. Oil level low warning light - what oil to buy, on xmas day?
    By drewbee in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 2
    Last Post: 25th December 2009, 11:32
  5. OIL warning light!
    By Mart in forum A4/S4 forum(B5 Chassis)
    Replies: 30
    Last Post: 17th March 2009, 17:59

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO