Sky InsuranceEM Tuning
Results 1 to 28 of 28
Like Tree1Likes
  • 1 Post By S3Zek

Thread: haldex prob

  1. #1
    S3Zek's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2011
    Posts
    407

    haldex prob

    hi all just wondered if anyone can shed some light on my mates prob ive serched the threds for some one that mite have had the same probs but no luck, it a apy 2000 but with esp but dosnt seem to have a fuse in the car for the heldex, basickly it dosent work at and it has no faults showing, it didnt have an earth strap so one was put on and the plug at the back was clean, i was thinking controler? but wouldnt that bring up a code? it will show lo on the vagcom when the ignisihon is on then hi when the car is started, when it primes should it sound sort of like a fuel pump sounding or just a very small quiet electronic noise? (sorry about spelling im s**t i know lol)

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    jojo's Avatar
    S3 Drift King!

    Status
    Offline
    Join Date
    Sep 2003
    Location
    Solihull, Midlands
    Posts
    25,613
    Alright Zek, my 99 APY S3 doesn't have a fused Haldex, but my 2000APY with ESP that I sold to Gops definitely had a fused Haldex! Off the top of my head, it's fuse31, though I could be a mile out.



    99' Audi S3(APY) - Brilliant Black Click>>>Going Sideways vid!
    You've got to have a laugh! For Sale:LCR Brakes - £400



  4. #3
    S3Zek's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2011
    Posts
    407
    hi bud, yeah will get him to have another look failing that do you think controler maybe?

  5. #4
    S3Zek's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2011
    Posts
    407
    had a look this morning, your right bud but its not blown, any other ideas? dont surpose you have another controler to sell that we could try for beer money of corse

  6. #5
    Gops's Avatar
    6th gear @7000rpm

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Coventry
    Posts
    2,641
    Mine was definately the controller. Does your ESP light show when you drive? I fitted what looks like an older controller but it's working fine.
    Quote Originally Posted by <tuffty/> View Post
    its either mapped or broken...

  7. #6
    S3Zek's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2011
    Posts
    407
    now you say it yes he has had the light come on and stay on till he turns the car off and on again when he drives it hard, it hasent for a while tho,

  8. #7
    S3Zek's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2011
    Posts
    407
    didnt yours show faults tho?
    col_s3 likes this.

  9. #8
    Gops's Avatar
    6th gear @7000rpm

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Coventry
    Posts
    2,641
    My light was on constantly. I never had mind on vagcom but it should throw up a code for the controller but not 100% sure. Worth checking the connections with the contrOller first before replacing.
    Quote Originally Posted by <tuffty/> View Post
    its either mapped or broken...

  10. #9
    S3Zek's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2011
    Posts
    407
    yeah i checked the plug at the back of the diff is there any more above? on the top of where the controller is for instance?

  11. #10
    jojo's Avatar
    S3 Drift King!

    Status
    Offline
    Join Date
    Sep 2003
    Location
    Solihull, Midlands
    Posts
    25,613
    Quote Originally Posted by Gops View Post
    My light was on constantly. I never had mind on vagcom but it should throw up a code for the controller but not 100% sure. Worth checking the connections with the contrOller first before replacing.
    I think it threw up 'No comms to Haldex' on scan Gops, or nothing at all on your car.



    99' Audi S3(APY) - Brilliant Black Click>>>Going Sideways vid!
    You've got to have a laugh! For Sale:LCR Brakes - £400



  12. #11
    S3Zek's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2011
    Posts
    407
    it threw up No comms to Haldex when ignition was off but i assumed that is normal as there would be no power to it? other wise it said no faults found.

  13. #12
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Offline
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,621
    Quote Originally Posted by S3Zek View Post
    it threw up No comms to Haldex when ignition was off but i assumed that is normal as there would be no power to it? other wise it said no faults found.
    Ignition needs to be on to communicate to any module in VCDS...

    If it can't talk to the haldex its not going to show any faults as the faults are held in the controllers memory IIRC

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  14. #13
    S3Zek's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2011
    Posts
    407
    Quote Originally Posted by <tuffty/> View Post
    Ignition needs to be on to communicate to any module in VCDS...

    If it can't talk to the haldex its not going to show any faults as the faults are held in the controllers memory IIRC

    <tuffty/>
    i guessed that would be the case i just tried it out of curiosity, im new to playing with the vcds lol

  15. #14
    S3Zek's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2011
    Posts
    407
    tryed another controller but no diff (is a working one) whats the best way to check the pump? or can you just skick 12v up its arse? lol

  16. #15
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Offline
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,621
    Quote Originally Posted by S3Zek View Post
    tryed another controller but no diff (is a working one) whats the best way to check the pump? or can you just skick 12v up its arse? lol
    The haldex can be tested with VCDS but I don't know the details of how... one of the yank forums may have some info as its the same for TT's and R32's...

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  17. #16
    S3Zek's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2011
    Posts
    407
    manged to do the output test with vcds, its making some noises.... going to try the same on my one is a min to see if they differ

  18. #17
    S3Zek's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2011
    Posts
    407
    tried on my one and we deff think its the pump as his just makes a clonk lol erm... anyone got one to sell as audi want 400

  19. #18
    Reverse Gear

    Status
    Offline
    Join Date
    May 2012
    Posts
    9
    hi, i got the same problem..looking to swap the control...is it easy to do...my garage reckon they would have to drop the diff to get to it!!..i thought it was just two bolts? any help appreciated
    cheers

    rich

  20. #19
    s3 Hoggy's Avatar
    Whats going on???

    Status
    Online
    Join Date
    Apr 2009
    Location
    Oxford
    Posts
    1,653

    My Social Networking

    Visit s3 Hoggy's Instagram Channel
    I done my controller on the driveway with no ramps or even jacking it up, it's a bit of a pain in the ass but not difficult. You don't need to drop the diff! In fact if I remember correctly you can get straight at it mate
    2002 S3 REVO
    Milltek, Sachs Organic clutch, 007p, Genuine RSTT's, BBS RS2's
    Koni FSD & H&R springs, Neuspeed 22mm rear ARB, KW tie arms
    LCR Brembo's with DS2500's & Paul's 300mm Rear disc kit,
    Michelin Pilot Sport 3's,Badger5 V2.2 Jetex filter & heatshield


  21. #20
    4th Gear

    Status
    Offline
    Join Date
    Sep 2010
    Location
    Devon
    Posts
    756
    Same as S3Hoggy, I did mine on the drive, super easy process, admittedly its a bit fiddly at times doing it on your back with only a few inches of clearence tho, best advice is to wear something to cover your eyes as you'll get a lot of crap in them!!!
    Badger 5 tuned 340 bhp / 350 lbft sleeper

  22. #21
    4th Gear

    Status
    Offline
    Join Date
    Oct 2011
    Posts
    760
    To check your pump
    Check the electrical plug is ok, its behind a little shield on the rear diff.
    If there oil in the plug, your seals on the pump have gone.
    New pump time, some guy on the bay sells refurbs for 120 plus postage although he hasnt got any at the moment.
    Volvo use the same kinda pump, thinks its called the dem on there cars.
    read this excellent write up about the pre charge pump VWVortex.com - Haldex pre-charge pump removal / disassembly PIC HEAVY

  23. #22
    Reverse Gear

    Status
    Offline
    Join Date
    May 2012
    Posts
    9
    good news..thanks fellas....on the lookout for a control now then gonna hard wire it in...take the plug out the equation
    cheers

  24. #23
    Reverse Gear

    Status
    Offline
    Join Date
    May 2012
    Posts
    9
    on the subject of the control my car is a 210 APY does the replacement unit have to come from the same year and engine model and would it need coding .or is it a straight swap.
    thanks again
    rich

  25. #24
    4th Gear

    Status
    Offline
    Join Date
    Sep 2010
    Location
    Devon
    Posts
    756
    Only thing to watch out for when buying a replacment is ESP, if yours doesn't have it then you've got to buy one from another car that doesn't and vice versa... Other than that theres no coding or anything like that, just an oil and filter change
    Badger 5 tuned 340 bhp / 350 lbft sleeper

  26. #25
    S3Zek's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2011
    Posts
    407
    If you do go down the pump route if the controler dosnt fix it I did find that I had to remove the bolts on the prop at the back then leaver it out the way a little to help get the pump out on my mates one, also don't forget to get a replacement gasket as his was split when the pump was removed, Pump did fix the prob in his case in the end and works spot on.

  27. #26
    thegoal007's Avatar
    Another S3 owner....

    Status
    Online
    Join Date
    Apr 2008
    Location
    surrey
    Posts
    729
    S3Zek, was reading your earlier posts and it wasn't clear when you were doing the output tests on the pump which sound was correct.

    What is the correct result when the pump output test : Should there be a buzzing sound, a clonk or no sound ?

    I'm sure years ago when i did the test it made a noticeable buzzing sound and thought that was correct action. Nowadays when i do the test there's just a faint single clunk noise ?
    Even though mine is the later model , I am hoping they work in principle the same.
    02 plate - 2002 - 225bhp - S3 - Ming Blue - completely standard - nuff said, OK there's a centre armrest, sunroof, BOSE speakers & black leather recaros, oh and the non OE chrome pack !

  28. #27
    S3Zek's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2011
    Posts
    407
    Yeah it should buzz a bit like a fuel pump but not quite as fast, if you have just a clonk then I would say its the pump like his was, my mates one would just make a clonk when you told it to engage and then again sometimes when it was told to release.

  29. #28
    Reverse Gear

    Status
    Offline
    Join Date
    May 2012
    Posts
    9
    replaced the control unit today..hard wired it in...esp light off...result! cheers all

 

 

Similar Threads

  1. S3 Alarm prob
    By ghill in forum A3/S3 Forum (8L Chassis)
    Replies: 4
    Last Post: 26th March 2011, 19:42
  2. thermostat prob???
    By A3tell in forum A3/S3 Forum (8L Chassis)
    Replies: 17
    Last Post: 6th December 2010, 12:54
  3. Misfiring prob
    By QuattroChris in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 34
    Last Post: 14th December 2008, 00:44
  4. remap prob?
    By Andrthms4 in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 8
    Last Post: 17th July 2007, 20:10
  5. Eye Prob
    By IsaiahAllison in forum General Chat
    Replies: 13
    Last Post: 17th May 2007, 18:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO