EM TuningAH Fabrications
Results 1 to 16 of 16
  1. #1
    baz_baz's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2011
    Location
    Blackpool
    Posts
    17

    Was happy to have VAGCOM working on my laptop. . . . until I saw all my errors!

    Well after a lot of f***ing around getting my Vagcom to work on my edition of windows 7 I scanned my S3. My shopping list has now changed slightly.
    I got the following errors:
    16486-MAF (G70) signal too low,
    18057-Powertrain Data Bus missing message from ABS controller
    17645,17646,17648-Cyl1,2,4 Fuel Injector (N30) Open circuit
    17521-Oxygen(LAMBDA) Sensor B1 S1 Internal resistance too high

    So the MAF and fuel injector problems prob explain the loss in power. Bin quoted £60 for a MAF this sound about right? on ebay I saw one for £192??? Vagcom suggests for the injector either, fuse?, wiring harness?, failed injector?, or failed ECM? Now I'm trying to order a service guide from Audi as I dont even no where to start checking these things? Could it be worth a try with some injector cleaner first?
    Then any tips on the ABS controller problem would be appriciated my VCom said chech brake elec + communication with brake elec??

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Y83OLK's Avatar
    Hulk Smash!

    Status
    Offline
    Join Date
    Sep 2009
    Posts
    838
    I would suggest clearing the faults, and seeing what re appears after a few hours driving.

    Sometimes codes like these are thrown up from the battery being a bit low etc.

  4. #3
    s3dave's Avatar
    TFSI Hybrid

    Status
    Offline
    Join Date
    Nov 2009
    Location
    west yorks
    Posts
    10,055
    Yes also they could be old faults that have been fixed, so as above clear them and check again in a few days..

  5. #4
    Jonesy's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Jun 2004
    Location
    Kent
    Posts
    570
    No harm in cleaning the MAF and injectors I'm sure theres guides on here. Cleaning MAF made a huge difference to my car.
    2001 Audi S3 - Facelift - Revo remap - Forge 007p DV - BMC Panel Filter- Type R Ariel - Aero wipers - n75j valve.

  6. #5
    baz_baz's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2011
    Location
    Blackpool
    Posts
    17
    cheers tomorrow i will wipe the codes and then retest later in the day see where I stand, I already bought some 'injector cleaner' just the stuff you put in with the fuel figured it was worth a try but I never knew you could clean a MAF will have a look for the thread.
    will update tomorrow see how get on with codes

  7. #6
    Chugger

    Status
    Offline
    Join Date
    Nov 2009
    Location
    North Devon
    Posts
    2,716
    If you do go for a new MAF, £60 is about right if you px your unit. I was quoted about that on Friday, that's a Bosch unit btw.

    Don't manic too much, as some faults can bring on others. I'd start with MAF as that's common to break... Mine has managed to get through one in 12 months it seems
    57 A3 2.0 TDI Sportback (140)

  8. #7
    Jonesy's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Jun 2004
    Location
    Kent
    Posts
    570
    MAF cleaning guide Waks Wide Web

    I literally removed the sensor from the casing and sprayed it with some alcohol spray I bought from Maplins.
    2001 Audi S3 - Facelift - Revo remap - Forge 007p DV - BMC Panel Filter- Type R Ariel - Aero wipers - n75j valve.

  9. #8
    baz_baz's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2011
    Location
    Blackpool
    Posts
    17
    cheers new MAFs on order but they never said anything about having my old one so am gonna give cleaning it a go anyway.

    So I cleared, or attempted to clear my codes.
    I put some of the mix with your petrol injector cleaner in had a little drive. Then I started clearing the codes (this took me longer than it should have as my VagCom keeps unregistering itself and becoming shareware?? anyone help me here?) anyway cleared them all but the ABS module cleared and became error 00778- Steering Angle Sensor, this code wouldnt clear returned instantly without driving or even starting car. Took it for a drive, and retested, only errors there was 18057-Powertrain Data Bus missing message from ABS controller, and the Steering Angle one. So some of my probs are fixed and tomorrow I will own a spare MAF. But I'm stuck with the errors I dont have a clue how to fix. Can anyone help me out?

  10. #9
    Chugger

    Status
    Offline
    Join Date
    Nov 2009
    Location
    North Devon
    Posts
    2,716
    I had that abs fault on a friends. Told him to take it to an autoelectrician and it turned out to simply be a connector to the abs unit which was a bit dodgy. I don't think you will be able to do much with that fault yourself, the steering angle sensor can appear if the car isn't tracked correctly btw
    57 A3 2.0 TDI Sportback (140)

  11. #10
    s3dave's Avatar
    TFSI Hybrid

    Status
    Offline
    Join Date
    Nov 2009
    Location
    west yorks
    Posts
    10,055
    Quote Originally Posted by baz_baz View Post
    cheers new MAFs on order but they never said anything about having my old one so am gonna give cleaning it a go anyway.

    So I cleared, or attempted to clear my codes.
    I put some of the mix with your petrol injector cleaner in had a little drive. Then I started clearing the codes (this took me longer than it should have as my VagCom keeps unregistering itself and becoming shareware?? anyone help me here?) anyway cleared them all but the ABS module cleared and became error 00778- Steering Angle Sensor, this code wouldnt clear returned instantly without driving or even starting car. Took it for a drive, and retested, only errors there was 18057-Powertrain Data Bus missing message from ABS controller, and the Steering Angle one. So some of my probs are fixed and tomorrow I will own a spare MAF. But I'm stuck with the errors I dont have a clue how to fix. Can anyone help me out?
    Check the connector under the car also the earth strap, like said if the geometry is out it will throw the steering angle code...

  12. #11
    baz_baz's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2011
    Location
    Blackpool
    Posts
    17
    The car had a 4 wheel laser alignment in July so hoping the tracking should be fine.
    I no an auto elec so a mite have him have a look over it just bit short for cash at the moment.
    And S3-Dave where abouts under the car am I looking? I'm trying to get a service manual from audi but not having much luck

  13. #12
    s3dave's Avatar
    TFSI Hybrid

    Status
    Offline
    Join Date
    Nov 2009
    Location
    west yorks
    Posts
    10,055
    On the back Axle are you will see the Haldex plug and earth strap

  14. #13
    Neutral

    Status
    Offline
    Join Date
    May 2011
    Posts
    80
    Quote Originally Posted by sportstractor View Post
    If you do go for a new MAF, £60 is about right if you px your unit. I was quoted about that on Friday, that's a Bosch unit btw.

    Don't manic too much, as some faults can bring on others. I'd start with MAF as that's common to break... Mine has managed to get through one in 12 months it seems
    whose quoting £60 for mafs cant seem to source bosch one for my AGU anywhere near that price!?!

  15. #14
    eddieantifreeze's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2011
    Posts
    164
    I just checked mine - No engine faults pinged up, however.....

    Codes for airbag crash detection and locking crash detection did ping up - great, i bought a nail......

  16. #15
    s3dave's Avatar
    TFSI Hybrid

    Status
    Offline
    Join Date
    Nov 2009
    Location
    west yorks
    Posts
    10,055
    Quote Originally Posted by a3Nate View Post
    whose quoting £60 for mafs cant seem to source bosch one for my AGU anywhere near that price!?!
    AGU MAFs are different and very expensive, unfortunatly

  17. #16
    Neutral

    Status
    Offline
    Join Date
    May 2011
    Posts
    80
    well at least i know that for sure now was beginning to think id entered 'mug' on every for sale site/parts outlet going!

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO