Monster MotorsportEM Tuning
Results 1 to 8 of 8
  1. #1
    Neutral

    Status
    Offline
    Join Date
    Jul 2009
    Location
    In a land far far away
    Posts
    35

    Clutch snap when pressing? 2 bits of plasitic and a slice of metal?

    Was going from 4th to 5th aroun4 40mph last night on the bye-pass and there was a loud clunk, the clutch pedal hit the deck and I pulled over, I found 2 bits of plasitic and a slice of metal in the foot well.............

    1x white plasic clip snapped
    1x black plasic cover? I thing
    1x 1.5" bit of metal?

    Clutch is fine in this car and just covered 100 miles in it about an hour before, not the master cylinder or anything like that, is this a common problem, can anyone shed any light, parts needed or a how to?

    I can see a metal rod and the pedal, I take it this was attached

    Cheers people!

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Inertiauk's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Mar 2011
    Posts
    529
    You need a new clutch pedal or to have yours welded back up, you will probably need to replace the plastic section too. about £35 for both parts from audi.

    S3 (2000) Clutch Problem - HELP!! - Audi Forums
    __________________________________________________ __________________________________________________ _
    Driving a 2004 B6 Audi S4 - Stage 2

    __________________________________________________ __________________________________________________

  4. #3
    Neutral

    Status
    Offline
    Join Date
    Jul 2009
    Location
    In a land far far away
    Posts
    35
    Indeed this was the problem and i have replaced the clutch peddle, and 2 plastic clips, but the pedel is now very high, and hard to change gear, any ideas on where i went wrong?

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2011
    Posts
    15
    This is very common , reason it's high is probably the clutch cable (ball end) is not in White clip properly
    Simple check is to pull pedal higher whilst lookin it'll pull apart

  6. #5
    DJ_Troopa's Avatar
    K1 Driver

    Status
    Offline
    Join Date
    Oct 2008
    Location
    West London
    Posts
    1,737

    My Social Networking

    Visit DJ_Troopa's Instagram Channel
    You might not have put it in properly then. I had mine done in December with new pedal and clips as mine snapped just like yours. When i got my car back the pedal was fine at the usual height.
    Inferi Black Cupra K1

    Click here for more Troo-Pics!


  7. #6
    Neutral

    Status
    Offline
    Join Date
    Jul 2009
    Location
    In a land far far away
    Posts
    35
    Cool beans people.... thank you......

    Also on that note, I snapped a little pin that was attached to a pinkish box? about 3" long and 2" wide (the box) the pin about 1cm'ish..

  8. #7
    Neutral

    Status
    Offline
    Join Date
    Jul 2009
    Location
    In a land far far away
    Posts
    35
    vw golf mk4 clutch pedal switch 1j0927189 200601 07174

  9. #8
    Inertiauk's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Mar 2011
    Posts
    529
    Mine did this tonight on the M62, RAC just got my car home (waited 2 hours on hard shoulder raaa), job for tommorow, bloody Audi!
    __________________________________________________ __________________________________________________ _
    Driving a 2004 B6 Audi S4 - Stage 2

    __________________________________________________ __________________________________________________

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO