JMB RetrofitsAH Fabrications
Results 1 to 13 of 13
  1. #1
    Naresh's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jan 2003
    Location
    Essex
    Posts
    260

    URGENT - BRAKE LIGHTS NOT WORKING!!

    Hi, I had new brake discs and pads fitted today but later found out this evening that my brake lights are not working now!! I can't be 100% sure that this was a direct result of the work done at the garage or indeed they weren't working before I got there but what do you guys think?

    I can't get to an Audi dealer until Thursday so can't drive it until then obviously! Where is the brake sensor switch and can I fix this myself?? I'd rather do that than fork out at Audi!! Could the garage have done something wrong for it to have stopped working?? (I need to know that before I phone them tomorrow to complain!!)

    Ugghhh......don't you just hate it when this happens!! [img]/ubbthreads/images/graemlins/mad.gif[/img]

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Ram
    Ram's Avatar
    Neutral

    Status
    Offline
    Join Date
    Jan 2003
    Location
    New Jersey, USA
    Posts
    83

    Re: URGENT - BRAKE LIGHTS NOT WORKING!!

    Hi Naresh,

    It should be on the pedal box, connected to the pedal.

    Usually, if someone changes the brakes, the switch is not affected.

    If the switch is not there, take a look on the master cylinder and servo for a microswitch.

    Don't panic - just be logical.

    Also - don't forget to check the fuse and BOTH bulbs.

    If you get stuck - call the RAC or AA to come out and take a look for you.

    Good luck,

    Ram

  4. #3
    CARACTERE007's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2003
    Location
    havin\' a giraffe
    Posts
    319

    Re: URGENT - BRAKE LIGHTS NOT WORKING!!

    its a bugger to get to under the pedal box,...the aa man took 3 hours to sort mine out last month,...ended up going to the dealer and forking out 75 to get the bugger fixed.....good luck naresh! [img]/ubbthreads/images/graemlins/frown.gif[/img]

  5. #4
    Naresh's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jan 2003
    Location
    Essex
    Posts
    260

    Re: URGENT - BRAKE LIGHTS NOT WORKING!!

    Thanks Ram, will check the fuse today before work but doubt the bulbs have gone because ALL 3 sets of brake lights aren't working.

    Where is the master servo located and if I call out the AA could they fix the problem - as Caractere mentioned he ended up going to Audi anyway! Guess a new switch is needed?

    I must have p####ed off enough people driving home last night!!

  6. #5
    CARACTERE007's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2003
    Location
    havin\' a giraffe
    Posts
    319

    Re: URGENT - BRAKE LIGHTS NOT WORKING!!

    yeah thast what mine did,..none of the lights worked at all,....the switch is right at the top of the brake pedal....a black push button type thing...its a tight squeeze but you could reach it,....the aa man sprayed some wd40 on it, that seemed to of done the trick for about 20 mins but then it went again,.....so it was trip to mr audi,...the part was relatively cheap....it ws just fitting the bugger as the bottom of the all that plastic had to be removed...good luck dude!

  7. #6
    1st Gear

    Status
    Offline
    Join Date
    Jan 2003
    Location
    liverpool
    Posts
    122

    Re: URGENT - BRAKE LIGHTS NOT WORKING!!

    same thing happened to me went to audi who kindly charged me 50 odd quid to fix it,the part is around 6,so that leaves a hell of alot for the work ......considering its a 2 min job to change. [img]/ubbthreads/images/graemlins/laugh_roll.gif[/img]

    most likely is your brake light switch !


  8. #7
    3rd Gear

    Status
    Offline
    Join Date
    Jan 2003
    Location
    Chepstow, South Wales
    Posts
    620

    Re: URGENT - BRAKE LIGHTS NOT WORKING!!

    Surely this sort of thing is covered under warranty though??!

    Alex.

  9. #8
    Naresh's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jan 2003
    Location
    Essex
    Posts
    260

    Re: URGENT - BRAKE LIGHTS NOT WORKING!!

    Hi people I've just located the brake switch attached to the top of the brake pedal - it was suprisingly easy to get to once the lower dash panel was removed! [img]/ubbthreads/images/graemlins/cool.gif[/img]

    As mentioned its a 5 minute job - just need to buy the part now and fit it! Is there anything else that could be causing the problem apart from this as I don't know how to test the switch!

  10. #9
    5th Gear

    Status
    Offline
    Join Date
    Jan 2003
    Posts
    1,361

    Re: URGENT - BRAKE LIGHTS NOT WORKING!!

    Well dependent on how how it's wired it should be simple, I take it has two wires? Probably yes. So the switch should be a normally open switch, meaning that the lights come on when it's closed. Way of testing...well take the two wires and short (Connect) them together, if the lights come on you know it's the switch...as simple as that.
    Dependent on the connections it may be possible to do the above, and you be able to check the switch with a simple continuity tester.

    It would be far better if the automotive industry did what we do in the forklift business for safety circuits which is use a normally closed switch, this way the lights come on when the circuit/switch is opened. So if a break in the wiring or the switch fails then the lights would come on constantly instead of nothing at all.

  11. #10
    Naresh's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jan 2003
    Location
    Essex
    Posts
    260

    Re: URGENT - BRAKE LIGHTS NOT WORKING!!

    Hi thanks for that! I just put a multimeter across the spade connector (switch removed) and it read 12V. When I connected the switch it still read 12V regardless of me closing or opening the switch! Does that mean the switch is working or not? Sounds confusing I know but thought I better check before risking a trip to the dealer for a new part!

    Also could you explain how to perform a continuity test on the switch please?

  12. #11
    5th Gear

    Status
    Offline
    Join Date
    Jan 2003
    Posts
    1,361

    Re: URGENT - BRAKE LIGHTS NOT WORKING!!

    The way you tested it will show 12 volts constantly, to test in that way you would need to put the meter to one side only.

    Continuity, on your meter should be a diode check (Triangle with a vertical bar behind it)and maybe a symbol similar to an echo ))), which when selected will show .OL to start with, then when you connect the meter lead tips together it should go to 0.01 or there abouts and may even bleep, dependent on the meter. Armed with this you can now put the meter leads either side of the switch and see it go from OL to 0.01 when pressing the switch, if it changes between the two...all is good. If you can remove the wires from the switch all the better.

    Let me know ASAP if you need more assistance, as I'm at home on my laptop on mobile phone connection, so can't hang for too long.....as it's a company phone bill.

  13. #12
    Naresh's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jan 2003
    Location
    Essex
    Posts
    260

    Re: URGENT - BRAKE LIGHTS NOT WORKING!!

    Thanks Gambba - your advice worked! I shorted the connector and hey presto the lights came on! So its off to Audi for a new switch! I then noticed a couple of the lights on the 3rd brake light weren't working.......quick tap on the spoiler and on they came!! [img]/ubbthreads/images/graemlins/groovy.gif[/img]

    Hope we can all learn from my problem! Then again...should the switch have failed so quickly anyway??

  14. #13
    Naresh's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jan 2003
    Location
    Essex
    Posts
    260

    Re: URGENT - BRAKE LIGHTS NOT WORKING!!

    Just to report back to everyone (incase someone else has this problem), I fixed the switch myself no problem and so avoided any messy confrontation with an Audi technician! [img]/ubbthreads/images/graemlins/tongue.gif[/img]

    The switch can actually be opened up with some patience and a small screwdriver. Once the parts have been dismantled you'll see that the 2 brass terminals (or in my case one) will be corroded and dirty. I simply cleaned these up with sandpaper and reassembled the switch.

    All brake lights now working no problem - fingers crossed!

    I may just pick up another switch just incase - its only 6 plus VAT anyway!

    Once again this site has provided me with another opportunity for a dealer-free fix! (and a peaceful nights sleep!! [img]/ubbthreads/images/graemlins/smile.gif[/img] )

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO