Chris NottBadger5
Results 1 to 27 of 27
  1. #1
    1st Gear

    Status
    Offline
    Join Date
    Jan 2011
    Location
    N.Ireland
    Posts
    149

    Oil Sensor Warning Light

    Why would this be coming on? Ive checked oil levels and the seem fine? Any ideas? Im going to do an oil change this weekend so would this maybe put the light off? Thanks for your help

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,273
    Could be a dodgy sensor or might be an issue with your oil pressure! Try doing an oil change and see if that makes any difference. If you have a pressure issue you really dont want to be driving the car too much.
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2009
    Posts
    16
    Mines the same that annoying beep and the oil sensor warring light, im sure this just relates to a faulty sensor. iv just had a service and its still beeping away but at over 70 for a new one ill live with if for a while.

  5. #4
    Broken Byzan's Avatar
    Photographic Moderator

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Cardiff, United Kingdom
    Posts
    12,520

    My Social Networking

    Follow Broken Byzan On Twitter Add Broken Byzan on Facebook Add Broken Byzan on Google+ Visit Broken Byzan's Youtube Channel
    If the light is red, stop driving and get the pick up in the sump changed before it costs you an engine

  6. #5
    finesse's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Aug 2006
    Location
    London / Anglia
    Posts
    2,814
    as above, small money incomparable with a new engine

  7. #6
    2nd Gear

    Status
    Offline
    Join Date
    Apr 2010
    Location
    Widnes Cheshire
    Posts
    404
    Yep, change the sensor, if light is still coming on then have it looked at as it may be a blocked oil pick-up or faulty pump.

    DC
    His: 2001 1.8T AUM. Hibiscus Red Pearl Effect - Hers: 2002 1.8T AUM. Metalic Silver.

  8. #7
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,273
    Quote Originally Posted by DenCar View Post
    Yep, change the sensor, if light is still coming on then have it looked at as it may be a blocked oil pick-up or faulty pump.

    DC
    Get the car scanned, it will be rare for the sensor to be duff but a VCDS scan will tell you. It will be easier and cheaper to get the oil pickup checked and cleaned/replaced rather than spend 80 on a sensor that might not be the problem.
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







  9. #8
    2nd Gear

    Status
    Offline
    Join Date
    Apr 2010
    Location
    Widnes Cheshire
    Posts
    404
    Quote Originally Posted by Westle View Post
    Get the car scanned, it will be rare for the sensor to be duff but a VCDS scan will tell you. It will be easier and cheaper to get the oil pickup checked and cleaned/replaced rather than spend 80 on a sensor that might not be the problem.
    Out of interest, how much approx for a new pick-up and oil pump + labour.

    DC.
    His: 2001 1.8T AUM. Hibiscus Red Pearl Effect - Hers: 2002 1.8T AUM. Metalic Silver.

  10. #9
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,273
    You shouldn't need a new pump or pickup pipe, just a clean and a new strainer which costs a few quid. A new pump and pickup pipe wont be particularly cheap.

    My mechanic charged me 80 to remove the sump, pressure test the oil pump, clean the oil pickup pipe, and replace the strainer (filter). But he was already doing a service so the sump was drained of oil anyway.
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







  11. #10
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2010
    Location
    Telford/Shropshire
    Posts
    366
    i had the same problem 3 weeks ago. its the oil pressure/ faulty sensor.
    deffo worths changing it, before you do some serious damage to the engine.
    Last edited by TOM.S; 24th February 2011 at 15:01.

  12. #11
    Neutral

    Status
    Offline
    Join Date
    Jan 2011
    Posts
    36
    I've got the same problem
    red light with 3 beeps

    Oil levels are fine, i think i put a little too much in since i didnt really have the car on level ground and it messed up
    this was after i busted my sump and fitted a new one in

    Vagcom didnt throw up any errors regarding it

    i was told by a friend, its probably a faulty oil pressure switch. Been driving the car for the last 2 months been absolutely fine in every way
    Its due a service nowish,
    so will be changing oil again and new oil filter etc

    hopefully itl go away. anyone know what else it could be

    Dont europarts have the oil pressure switch for under a tenner

  13. #12
    1st Gear

    Status
    Offline
    Join Date
    Jan 2011
    Location
    N.Ireland
    Posts
    149
    My light isn't red though its orange and has an oil can with sensor written beside it. Your problem may be bigger than mine by the sounds of it if it's red?

  14. #13
    danger S3's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jun 2010
    Location
    Edinburgh, Scotland
    Posts
    355
    defiantly check your oil pickup in the sump isnt blocked as that can be the killer for loads of engines

    S3 Sump Removal and Refit (with pics)

  15. #14
    s3dave's Avatar
    TFSI Hybrid

    Status
    Offline
    Join Date
    Nov 2009
    Location
    west yorks
    Posts
    10,121
    How can you drive around with that thing flashing.....it would be mind wars with me......it bugs me when the washer fluid is low.....
    just think of a worse case scenario ...if it is on because of a dodgy switch, what can it do extra if things become worse and the pressure actually drops....it would not do any extra warnings....... that is your final warning!!!

  16. #15
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,273
    I agree with Dave, that is one warning i wouldn't be driving around with!
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







  17. #16
    Neutral

    Status
    Offline
    Join Date
    Jan 2011
    Posts
    36
    It's been 4months and about 3k miles lol
    Will have it checked out by a mech

    Mind you
    It doesn't do his at high speed or motorway
    But as soon as I drop from high to low speed
    The light beeps

  18. #17
    2nd Gear

    Status
    Offline
    Join Date
    Apr 2010
    Location
    Widnes Cheshire
    Posts
    404
    I would think that at high speed your pump is working harder and pumping the oil at a higher pressure, at lower speed the pump is working less hence less pressure, i may be wrong about this, but i would be a little concerned if i were you.

    DC
    His: 2001 1.8T AUM. Hibiscus Red Pearl Effect - Hers: 2002 1.8T AUM. Metalic Silver.

  19. #18
    Sandip's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Nov 2006
    Location
    Greater Manchester
    Posts
    2,379
    It's either your pick up or your oil pump. Either way if you have the sump off to do the pick up, you may aswell do the pump at the same time

    What service are you on, longlife (5w30) or regular (5w40,10w40)?
    3.2 V6 with Custom Code VVT Attack Software


  20. #19
    jojo's Avatar
    S3 Drift King!

    Status
    Offline
    Join Date
    Sep 2003
    Location
    Solihull, Midlands
    Posts
    25,505
    Quote Originally Posted by physk View Post
    Oil levels are fine, i think i put a little too much in since i didnt really have the car on level ground and it messed up
    this was after i busted my sump and fitted a new one in
    Becareful with over filling these 1.8T's, a friend of mine mistakenly thought the low oil pressure warning as being low engine oil and overfilled his 1.8T on his Passat, it was halfway up the dipstick! He's an old chap mind, and he never thought of checking his dipstick first before filling! Anyways, the results of this is the oil came up the breather and filled the intercooler with oil, and it also pushed a load of crap into his sump, which blocked the oil pickup, so no oil pressure and a seized engine!!



    99' Audi S3(APY) - Brilliant Black Click>>>Going Sideways vid!
    You've got to have a laugh! For Sale:LCR Brakes - £400



  21. #20
    Neutral

    Status
    Offline
    Join Date
    Jan 2011
    Posts
    36
    I'm going to change my oil when I service my car in the next few days
    Putting 5w40 in

    Whilst I had these probs I just put in castrol 10w40
    Just to double-check there wasn't any leaks elsewhere
    I've verified that

    So now its just do te service and hope the noise goes away
    Really annoying an worrying sometimes

  22. #21
    1st Gear

    Status
    Offline
    Join Date
    May 2006
    Location
    Lancs
    Posts
    211
    Is the 10w40 not semi synth though?

  23. #22
    Neutral

    Status
    Offline
    Join Date
    Jan 2011
    Posts
    36
    It is indeed

    It was always meantto be temporary
    It was put after the sump job to ensure that everythig was fine

    Just haven't had time since then to change it since I'm moving between Manchester and Sunderland

  24. #23
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,370
    If its yellow and says "SENSOR" at the bottom its a fault with the oil LEVEL sensor, which sits in the sump and registers how much oil is in the sump.

    If its this, then its possibly just a wiring fault, or a sensor fault, and isnt a big issue so long as there is actually oil in there.

    If its RED and says nothing at the bottom, its PRESSURE related, and continuing to drive the car will most likely result in a wrecked engine.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  25. #24
    1st Gear

    Status
    Offline
    Join Date
    Jan 2011
    Location
    N.Ireland
    Posts
    149
    Quote Originally Posted by aragorn View Post
    If its yellow and says "SENSOR" at the bottom its a fault with the oil LEVEL sensor, which sits in the sump and registers how much oil is in the sump.

    If its this, then its possibly just a wiring fault, or a sensor fault, and isnt a big issue so long as there is actually oil in there.

    If its RED and says nothing at the bottom, its PRESSURE related, and continuing to drive the car will most likely result in a wrecked engine.
    Im in the yellow situation thank you

  26. #25
    1st Gear

    Status
    Offline
    Join Date
    Jan 2011
    Location
    N.Ireland
    Posts
    149
    Did my oil change today found the problem, the oil sensor had become unplugged, problem solved thanks folks :D

  27. #26
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,273
    Nice one. At least it's not a blocked pickup.
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







  28. #27
    Neutral

    Status
    Offline
    Join Date
    Jan 2011
    Posts
    36
    hopefully my problem sorts out just as easily

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO