Monster MotorsportAH Fabrications
Results 1 to 9 of 9
  1. #1
    Neutral

    Status
    Offline
    Join Date
    Jan 2011
    Posts
    86

    Haldex and Esp Help

    Hi I'm a fairly new S3 owner , looking for some advice / help ref esp . I have no light on dash ref esp
    only bought the car a month ago , loving it but ironing out a few issues . Firstly think that the bulb ref esp may have been removed from the dash . Also after having a key programmed by audi recently
    i asked them to do a diagnostic log which came back with G85 fault (steering angle sender) implausible signal sporadic . So my question is if there's a fault with esp does that mean esp system is totally inop and what or how does this affect the haldex system ? if at all ! I can live without esp as long as my haldex is unaffected . Many thanks .

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    superkarl's Avatar
    MAN OF STEEL

    Status
    Offline
    Join Date
    Mar 2010
    Location
    Liverpool/Southport. N west
    Posts
    7,533
    As far as I know your Haldex should be ok. Only ESP affected by that. With that fault your ESP light should be on once moving. Does your car have ESP, some older ones don't.

  4. #3
    Neutral

    Status
    Offline
    Join Date
    Jan 2011
    Posts
    86
    Hi Karl ,
    Thanks for the reply , so are you saying that the haldex controlls the esp not vice versa ? Mines an 02 plate S3 definitley has esp as i have the switch on the dash . However no esp light on the rev counter when switching on ignition . Me thinks the bulb has been removed to mask this fault before i bought the car dirty trick eh ! Many thanks ,
    Ant

  5. #4
    superkarl's Avatar
    MAN OF STEEL

    Status
    Offline
    Join Date
    Mar 2010
    Location
    Liverpool/Southport. N west
    Posts
    7,533
    Can you feel the ESP working at all when pushing it, if you do You'l know it's the light, which I'm not sure on how to change.
    It's a very complicated system, with that fault I would imagine ESP not working, the 4wd should still be ok though. If the 4wd wasn't working, the ESP wouldn't. Lol, confusing i know. My 4wd is faulty, which in turn switches ESP off, only some days though, which makes me want to bang my head against a wall.

  6. #5
    superkarl's Avatar
    MAN OF STEEL

    Status
    Offline
    Join Date
    Mar 2010
    Location
    Liverpool/Southport. N west
    Posts
    7,533
    To elaborate, the ESP depends on the 4wd working. Not the other way around.

  7. #6
    AudiS3Quattro's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    201
    sorry to hijack your thread, but I had a diagnostics from Audi last week and they told me that my haldex control unit was broke, and they told me my 4wd was not working at all resulting in me having a 2wd s3, which i thought was the case as it drove horribly compared to my previous s3. However I do dtill get my ESP light working when the car looses traction, so by what people are saying surley if my haldex 4wd was inoperative then my ESP would be Inoperative too? help me too please!!
    2003 BAM Nogaro Blue S3, Revo Stage 2, Approx 270BHP Miltek Exhaust With THS De-cat, Neuspeed P-Flow, Forge Split-R DV, 19" Rail Daytona's 9'' Rears, 8'' Front, Stretched Tyres, Euro Look, 20mm H&R Rear Wheel Spacers, 10mm Front Wheel Spacers, H&R Springs, Chrome Mirrors, Piano Black Dash, Black Recaro Heated Leather, Xenon Headlights, LOW and WIDE!

  8. #7
    Neutral

    Status
    Offline
    Join Date
    Jan 2011
    Posts
    86
    I've never felt ESP cut in or any loss of power to point , am pretty sure the haldex is working as the car was great in the snow and i did nearly 600 miles in it at christmas time to get it home , on very icy roads . Thanks Carl , think you've answered my question on ESP , i guess its one for me to sort in the future , i.e open up the dash pod and replace the bulb and look into getting a new clock spring to clear the G85 fault and get my ESP back ! Hope you get your haldex sorted , i have read there can be a problem with a broken earth strap leading to the haldex , maybe worth looking into ! Many thanks all . Will update at a later date

  9. #8
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2009
    Location
    West london
    Posts
    379
    I have g85 fault is well steering angle sensor light should be on the dash and this shouldn't affect ur 4wd system as mine still works.
    I would say bulb was removed to hide this fault

  10. #9
    s3dave's Avatar
    TFSI Hybrid

    Status
    Offline
    Join Date
    Nov 2009
    Location
    west yorks
    Posts
    10,121
    It can be rectified by getting a 4 wheel alignment done in some cases, if it has had suspension work done

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO