JMB RetrofitsChris Nott
Results 1 to 4 of 4
  1. #1
    coopsS3's Avatar
    Woosh Woosh Wah...

    Status
    Offline
    Join Date
    May 2010
    Location
    Manchester
    Posts
    32

    New Diff Fitted Today!!!! Need Help with 4 codes...

    Right so ive had the dredded haldex problems... ESP light started to come on now stays on so i did my homework and spoke to a few specialists. ive done the handbrake check and its showed me i had diff problems but before i forked out, i did a full service on my rear diff. No Change

    So i sourced a diff/haldex 40k it had done payed 250! today i had it fitted, again full service... drive home seemed sweet and specialist assured me the wheels locking during 3 point turns had stopped but the ESP light was still on....

    The following faults came up on diagnostics


    • 01312 Data Bus Drive
    • 01314 Engine Control Module
    • 01316 Brake Control Module
    • 01324 All Wheel Drive Module
    So im no expert and new to all this but these sound like expensive parts... so am i right in thinking that these parts simply throw up the code to tell you where to look?

    Also if ive got the same problem on my new diff surely this means its other sensors or earth straps causing the diff/haldex to fail?

    Can anyone with experience with this problem possibly list parts i should look at servicing or replacing i.e ABS sensors and so on

    Many thanks to all who reply ive had enough of this problem and wanna see how big a job its gonna be and make the decision whether i keep the car i love or sell and leave the stress behind.......

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    superkarl's Avatar
    MAN OF STEEL

    Status
    Offline
    Join Date
    Mar 2010
    Location
    Liverpool/Southport. N west
    Posts
    7,520
    check all your wires to and from the haldex, ecu, and abs module.

    i've got same esp problem, yesterday though it dissapeared alll day for the first time in weeks, then this morning, it was back. got to be electronic for me.
    seeing as though you've changed the mechanical, id put yours down to electronic fault also.

    so get them wires checked wherever you can see. il be doing the same this weekend. goodluck

  4. #3
    hharry100's Avatar
    Neutral

    Status
    Offline
    Join Date
    Feb 2007
    Location
    west london
    Posts
    52
    try disconnecting the battery and leave for 15mins after you have cleared the faults hopefully it may reset ecu! worth a try
    Dolphin grey 03
    Gmbh handling pack
    Defcon 2
    H&R roll bars
    RNS-E (dvd, Digital tv tunner)
    Custom Code
    Porsche Brake set-up
    Dieselgeek stigma short shift
    *NEW* 8P s3 FBMFSW

  5. #4
    Biggied's Avatar
    They called him mellow yellow.

    Status
    Offline
    Join Date
    Feb 2006
    Location
    Scotland
    Posts
    202
    looks like a drive can coms fault, are you able to speak to all drive can ecus? check pins 7 & 8 on the 8 pin plug, the wires should be orange with purple,green or brown tracer, theses are the can low & high data wires, check for contact corrosion & slack terminals then do the same for pin 2 as that should be a brown earth wire for the module, then also check the big main diff earth strap for obvious signs of damage & that is getting a good earth. I'd give the hole 8 pin plug a good going over anyway & when checking terminals don't asume because they visually look ok that they are, I've traced a few sporadic faults in the past caused by slack female terminals that have only been seen when inserting a spare male terminal into it then feeling there lack of grip/contact.

    Ewan.
    210hp 8L S3 quattro.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO