Monster MotorsportAH Fabrications
Results 1 to 5 of 5
  1. #1
    Neutral

    Status
    Offline
    Join Date
    Aug 2010
    Posts
    40

    S3 Heater Blower Doesn't Work

    Doesn't work at all, the climate panel works, can hear the flaps moving behind the dash but no fan. Checked fuses but not that.

    Any ideas what it could be?

    Thanks

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    bengal's Avatar
    3rd Gear
    Eskiv Champion

    Status
    Offline
    Join Date
    Sep 2010
    Location
    Staffordshire
    Posts
    537
    Probably the relay if it has one it should be under the panel above the pedals. Id do a search to see which one operates this first as there will be a few under there. If not that then the fan itself. Hope this helps.

  4. #3
    Neutral

    Status
    Offline
    Join Date
    Oct 2008
    Location
    Sunny Suffolk
    Posts
    69
    if not ^ then prob is the fan, located under/behind glove box, think it cost about 200 IRC?
    jabba..dabba..doood!
    Now for sale (51) S3
    PM me!

  5. #4
    Neutral

    Status
    Offline
    Join Date
    Aug 2010
    Posts
    40
    Half sorted, it was the connector that clips onto the fan unit. Wiggled it until it worked lol. If it stops again I'll have a look at dismantling the unit and see what's going on.

  6. #5
    Lemon S3's Avatar
    Alex

    Status
    Offline
    Join Date
    Sep 2009
    Location
    Bicknacre, Essex
    Posts
    1,314
    Have a look at this buddy Heater Blower quick fix guide and removal
    1999 APY S3 Imola Yellow

    PS3: Broady_11

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO