Sky InsuranceMonster Motorsport
Results 1 to 8 of 8
  1. #1
    1st Gear

    Status
    Offline
    Join Date
    May 2006
    Location
    Surrey
    Posts
    175

    Oil Light, Pressure, sensor???

    Hi Guys,
    My oil light keeps coming on and I think it only happens when I'm boosting quite hard. Obviously I've checked the oil and its fine, what other reasons could there be that its coming on?
    Does it also come on for oil pressure?
    Could it just be a faulty sensor?
    I've given it a scan and no faults came up.
    Thanks for your help.
    Audi S3 2001. Black on Black. OE Sat Nav/Freeview. Bose. 18" Audi/BBS Splits. 10+16mm Spacers. KW Coilovers. Forge DV,tip and intercooler pipes. KnN Panel Filter. Oh and the essential Re-map. GONE

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Welly's Avatar
    Testing dodgy Chinese gear...

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Gloucestershire
    Posts
    10,680
    The oil light as in the big red flashy beepy one?

    The oil light coming on is bad. Full stop.

    2 main causes:

    1) Shot oil pump

    2) Oil pickup pipe blocked (would be the millionth time - very common)

    Either way, I would really look at getting it sorted - the potential results of no oil pressure aren't pretty.

    It could be a faulty sensor - I have had one in the past - but that's not normally the case.
    ------------------------------------------------------------------------------------------
    "Marriage is like a coffin and each kid is another nail."
    Homer Simpson

    Quote Originally Posted by Prawn View Post
    Wellyboots, you are quite literally my most favourite pikey in the entire world




  4. #3
    FactionOne's Avatar
    Administrator

    Status
    Offline
    Join Date
    May 2004
    Location
    Preston
    Posts
    3,052
    As above, biggest bet is clogged pick-up at sump.

    Best advice - don't 'boost quite hard' until you've sorted it. You might be lucky and sort it out with an oil change (so long as you use some decent flush and drop it quite warm); but don't put Mobil1 in, and be gentle testing when you've got fresh oil (let it warm up, then gently touch 3000rpm to see if the light comes back on).

    If it still doesn't go away you'll probably have to do as we did to my A4, drop the sump, scrub it out, and fit a new oil pump...

    Regards,

    Rob.
    Boot full of dog. Back seat full of lenses.

  5. #4
    1st Gear

    Status
    Offline
    Join Date
    May 2006
    Location
    Surrey
    Posts
    175
    Ok thanks very much, I'll give it an oil/ filter change and a good flush through. If that doesn't sort it then what sort of money am I looking at for a new oil pump + labour?
    Audi S3 2001. Black on Black. OE Sat Nav/Freeview. Bose. 18" Audi/BBS Splits. 10+16mm Spacers. KW Coilovers. Forge DV,tip and intercooler pipes. KnN Panel Filter. Oh and the essential Re-map. GONE

  6. #5
    1st Gear

    Status
    Offline
    Join Date
    May 2006
    Location
    Surrey
    Posts
    175
    Also are there any signs that I should be looking out for? Engine running hot etc?
    Audi S3 2001. Black on Black. OE Sat Nav/Freeview. Bose. 18" Audi/BBS Splits. 10+16mm Spacers. KW Coilovers. Forge DV,tip and intercooler pipes. KnN Panel Filter. Oh and the essential Re-map. GONE

  7. #6
    Welly's Avatar
    Testing dodgy Chinese gear...

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Gloucestershire
    Posts
    10,680
    Quote Originally Posted by ben_turbo1 View Post
    Also are there any signs that I should be looking out for? Engine running hot etc?
    Noises are the key. Rattling from the top end indicates a lack of oil pressure in the head.
    ------------------------------------------------------------------------------------------
    "Marriage is like a coffin and each kid is another nail."
    Homer Simpson

    Quote Originally Posted by Prawn View Post
    Wellyboots, you are quite literally my most favourite pikey in the entire world




  8. #7
    Welly's Avatar
    Testing dodgy Chinese gear...

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Gloucestershire
    Posts
    10,680
    Quote Originally Posted by ben_turbo1 View Post
    Ok thanks very much, I'll give it an oil/ filter change and a good flush through. If that doesn't sort it then what sort of money am I looking at for a new oil pump + labour?
    New oil pump is here at Euro Car Parts: Topran Audi - Euro Car Parts UK

    Not sure about labour to be honest, it depends on what is being done.

    Whilst changing the pickup pipe/oil pump isn't a long jump, clogged pickup pipes normally go hand in hand with minging sumps.

    You will want to clean this at least. To be fair, many have opted to just fit a new one (OEM part from Audi) as it works out cheaper than labour to clean to sump out.
    ------------------------------------------------------------------------------------------
    "Marriage is like a coffin and each kid is another nail."
    Homer Simpson

    Quote Originally Posted by Prawn View Post
    Wellyboots, you are quite literally my most favourite pikey in the entire world




  9. #8
    1st Gear

    Status
    Offline
    Join Date
    May 2006
    Location
    Surrey
    Posts
    175
    Looks like this week is going to be yet another expensive audi maintenance week. Was gonna go to Audi today and get a new lateral sensor and coolant temp sensor so will pop in Euro car parts and get the oil today as well.
    Audi S3 2001. Black on Black. OE Sat Nav/Freeview. Bose. 18" Audi/BBS Splits. 10+16mm Spacers. KW Coilovers. Forge DV,tip and intercooler pipes. KnN Panel Filter. Oh and the essential Re-map. GONE

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO